summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmpinboard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmpinboard')
-rw-r--r--x11-plugins/wmpinboard/Manifest1
-rw-r--r--x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch11
-rw-r--r--x11-plugins/wmpinboard/metadata.xml5
-rw-r--r--x11-plugins/wmpinboard/wmpinboard-1.0.ebuild31
4 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/wmpinboard/Manifest b/x11-plugins/wmpinboard/Manifest
new file mode 100644
index 000000000000..649109de4c3d
--- /dev/null
+++ b/x11-plugins/wmpinboard/Manifest
@@ -0,0 +1 @@
+DIST wmpinboard-1.0.tar.gz 133290 SHA256 a0268bf1c6c0c9c7ac4167031970e17a298f0ab5a85bf6ef166ae454f205137c
diff --git a/x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch b/x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch
new file mode 100644
index 000000000000..7d2c94458b52
--- /dev/null
+++ b/x11-plugins/wmpinboard/files/wmpinboard-1.0-segfault.patch
@@ -0,0 +1,11 @@
+--- src/wmpinboard.c 2000-04-13 13:01:17.000000000 +0200
++++ src/wmpinboard.c 2003-03-06 19:29:57.000000000 +0100
+@@ -165,7 +165,7 @@
+ char t[STRING_BUF_SIZE];
+ FILE *file;
+ int pid = (int) getpid();
+- static int sizes[6];
++ static int sizes[7];
+ sizes[0] = size_0;
+ sizes[1] = size_1;
+ sizes[2] = size_2;
diff --git a/x11-plugins/wmpinboard/metadata.xml b/x11-plugins/wmpinboard/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmpinboard/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
new file mode 100644
index 000000000000..88f3b34b3bcd
--- /dev/null
+++ b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Window Maker dock applet resembling a miniature pinboard"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/131/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/93"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc alpha amd64 ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/wmpinboard-1.0-segfault.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}