summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-06-27 22:38:49 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-27 22:41:37 +0300
commit389791c4f56fbfbac1cae198187b23afcea6fc43 (patch)
treed7ee6e447af602d64b4ed080bbcc9db654bab2d0 /x11-terms
parentx11-libs/qtermwidget: add 2.0.1 (diff)
downloadgentoo-389791c4f56fbfbac1cae198187b23afcea6fc43.tar.gz
gentoo-389791c4f56fbfbac1cae198187b23afcea6fc43.tar.bz2
gentoo-389791c4f56fbfbac1cae198187b23afcea6fc43.zip
x11-terms/qterminal: add 2.0.1
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/qterminal/Manifest1
-rw-r--r--x11-terms/qterminal/qterminal-2.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-terms/qterminal/Manifest b/x11-terms/qterminal/Manifest
index 4539898fd0bf..84782a4ead7b 100644
--- a/x11-terms/qterminal/Manifest
+++ b/x11-terms/qterminal/Manifest
@@ -1,3 +1,4 @@
DIST qterminal-1.3.0.tar.xz 217748 BLAKE2B 8da4e5388f13919cf67eb9931d4acd0e51b4b45a57acea1db1d8d98cfcec57e7b789e9b0f764fdefdfc71ff36b6a9722e2d389013b22872f8f730ebb1ff1d944 SHA512 f8cf2183da7af7869433b6057e20fba46be5cce30b75bdafb6cc0a5474e39fb1f2f8831f6841ca78f8b367f718ed2ee5a312a75850bc8192a37f20a6c5767a8d
DIST qterminal-1.4.0.tar.xz 219500 BLAKE2B 86ac46180a5f58b24a7bed40796af622fd4456e5b4bf58484cb1271a9bb41ae7688368e74245b36cab99a3309ab6132b3d0c188af460b3a7d543a9ad4a45eb1a SHA512 95c7fffa0a7a91dae338168748e1a9061eb7d393a083a70c59e3324f78ae8200e1e3bb07aa131564b208068e62fc744cc75e96694d70443559c7205ec9f91121
DIST qterminal-2.0.0.tar.xz 228584 BLAKE2B 5c1bbd536659becd3708806a46a967bd35b479947cdca0412d0b2fecd31ce64f1dc71266dd48f3280fbac4e3e534c5b99e43442a63b139fb8789f443e1c67197 SHA512 455ca913f38eed881af50eb17d4798985d546c3c633d4df8887316abd4a56e76d1f716dcaece471e092471c0381a328ca685ec27f4d4690e89087166dc7fb0a3
+DIST qterminal-2.0.1.tar.xz 229556 BLAKE2B f6afe5f7a1a169d17e52bed372f760ee9112ca533c1cb0e8adf5b659739f459f0764a723934bdaba629fec94617ec67f157252dc83982fadb7fd58ae66503955 SHA512 5587e52edf9cc2227584e8eebe742414d566b51dc1647b643d9af6710adbe38e5d84634e7ea073fcb71397e1de0fccb5ca1af544b629685d36b645da5dd80c3d
diff --git a/x11-terms/qterminal/qterminal-2.0.1.ebuild b/x11-terms/qterminal/qterminal-2.0.1.ebuild
new file mode 100644
index 000000000000..14dfb83303be
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets,X]
+ x11-libs/libX11
+ ~x11-libs/qtermwidget-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}