summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-07 14:51:35 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-07 15:40:20 +0200
commitff843bb783c554c3147a2ca5b08465ffa08d990c (patch)
treeab5dacf90b8eda26a9b82b3c442d9ac7820b5e04 /x11-themes
parentx11-themes/fluent-icon-theme: drop old 2022.11.30 (diff)
downloadgentoo-ff843bb783c554c3147a2ca5b08465ffa08d990c.tar.gz
gentoo-ff843bb783c554c3147a2ca5b08465ffa08d990c.tar.bz2
gentoo-ff843bb783c554c3147a2ca5b08465ffa08d990c.zip
x11-themes/fluent-icon-theme: bump to 2023.06.07
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/fluent-icon-theme/Manifest1
-rw-r--r--x11-themes/fluent-icon-theme/fluent-icon-theme-2023.06.07.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-themes/fluent-icon-theme/Manifest b/x11-themes/fluent-icon-theme/Manifest
index 8324059359ca..03f080f70e9f 100644
--- a/x11-themes/fluent-icon-theme/Manifest
+++ b/x11-themes/fluent-icon-theme/Manifest
@@ -1 +1,2 @@
DIST fluent-icon-theme-2023.02.01.tar.gz 5910433 BLAKE2B 8725381ffdf184e21fb44343a64cfc1ebb91b32abe9bf72a5abec16a49139ffbb5b9217232e068338ab311b6840064e8b99f912d1d886938ee0289d612d20640 SHA512 d6b5ef6b17e8207cefcab8d83f8a3cacff49d388fae5b5c6807f61c820d27a1c9cc96289a61cafdb2707fa912eaf50048264b653e191e26e33844b8dd1091013
+DIST fluent-icon-theme-2023.06.07.tar.gz 6213271 BLAKE2B f088caa2c54f73923bef12f8fd30a286fd6ab0829ca3d6c40aabd2ddb71d0c70c6718a69a7c7b6039d7e5506c313fbe8ea14bbf9252e5524d06fe6fce73ec664 SHA512 7e85613a58ce1fad4c8b0b31b81bfe9b226982ab8ede2413d87e89a12d78aeffef01f0a20fcaccfda6431a88e7798dc00a0a824a73f938e7daa48cb799588738
diff --git a/x11-themes/fluent-icon-theme/fluent-icon-theme-2023.06.07.ebuild b/x11-themes/fluent-icon-theme/fluent-icon-theme-2023.06.07.ebuild
new file mode 100644
index 000000000000..c1ca65370187
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/fluent-icon-theme-2023.06.07.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ie. 2021.12.20 -> 2021-12-20
+MY_PV="${PV//./-}"
+MY_PN="${PN^}"
+
+inherit xdg
+
+DESCRIPTION="Fluent icon theme for Linux desktops"
+HOMEPAGE="https://github.com/vinceliuice/Fluent-icon-theme"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+black +hardlink round"
+RESTRICT="binchecks strip test"
+
+BDEPEND="sys-apps/util-linux[hardlink(-)?]"
+
+src_prepare() {
+ default
+
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ dodir /usr/share/icons
+ local myinstallopts=(
+ --all
+ --dest "${ED}/usr/share/icons"
+ $(usev black '--black')
+ $(usev round '--round')
+ )
+ bash ./install.sh "${myinstallopts[@]}" || die "install script failed"
+
+ if use hardlink; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # installs broken symlink (by design, but we remove it due to QA warnings)
+ find "${ED}" -xtype l -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}