summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-10 11:05:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-10 11:21:40 +0200
commit3f1a8f072e2fb5712820ce4920717c9e5c36d744 (patch)
tree6f37e6b36da81c7d9fa155335873d8a4dd364c2c /xfce-extra
parentmedia-sound/kid3: drop 3.9.1-r1 (diff)
downloadgentoo-3f1a8f072e2fb5712820ce4920717c9e5c36d744.tar.gz
gentoo-3f1a8f072e2fb5712820ce4920717c9e5c36d744.tar.bz2
gentoo-3f1a8f072e2fb5712820ce4920717c9e5c36d744.zip
xfce-extra/xfce4-windowck-plugin: Fix shebangs for Python scripts
Closes: https://bugs.gentoo.org/869440 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild b/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild
index b6fd0528f2ac..25332bb6beb7 100644
--- a/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild
+++ b/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.5.0.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit xdg-utils
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-any-r1 xdg-utils
DESCRIPTION="Panel plugin to put the maximized window title and window buttons on the panel"
HOMEPAGE="https://gitlab.xfce.org/panel-plugins/xfce4-windowck-plugin/"
@@ -26,11 +28,17 @@ RDEPEND="
${DEPEND}
"
BDEPEND="
+ ${PYTHON_DEPS}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
"
+src_prepare() {
+ python_fix_shebang themes/*/*/generator.py
+ default
+}
+
src_install() {
default
find "${D}" -name '*.la' -delete || die