summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/performous/performous-1.0.ebuild4
-rw-r--r--games-arcade/performous/performous-1.1.ebuild6
2 files changed, 7 insertions, 3 deletions
diff --git a/games-arcade/performous/performous-1.0.ebuild b/games-arcade/performous/performous-1.0.ebuild
index 9fa6cdf80dac..fbdaa56aeedf 100644
--- a/games-arcade/performous/performous-1.0.ebuild
+++ b/games-arcade/performous/performous-1.0.ebuild
@@ -66,9 +66,11 @@ src_prepare() {
sed -i \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
-e '/ Z /s/ Z / ZLIB /' \
+ -e 's/Z_FOUND/ZLIB_FOUND/g' \
+ -e 's/Z_LIBRARIES/ZLIB_LIBRARIES/g' \
-e 's/Jpeg/JPEG/' \
-e 's/Png/PNG/' \
- game/CMakeLists.txt || die
+ {game,tools}/CMakeLists.txt || die
strip-linguas -u lang
}
diff --git a/games-arcade/performous/performous-1.1.ebuild b/games-arcade/performous/performous-1.1.ebuild
index 9d54a662e18e..1fcd585c42af 100644
--- a/games-arcade/performous/performous-1.1.ebuild
+++ b/games-arcade/performous/performous-1.1.ebuild
@@ -63,10 +63,12 @@ src_prepare() {
"${FILESDIR}"/${P}-linguas.patch
sed -i \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
- -e '/ Z /s/ Z / ZLIB /' \
+ -e '/ Z /s/ Z/ ZLIB/g' \
+ -e 's/Z_FOUND/ZLIB_FOUND/g' \
+ -e 's/Z_LIBRARIES/ZLIB_LIBRARIES/g' \
-e 's/Jpeg/JPEG/' \
-e 's/Png/PNG/' \
- game/CMakeLists.txt || die
+ {game,tools}/CMakeLists.txt || die
strip-linguas -u lang
}