summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sh/Manifest2
-rw-r--r--dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch22
-rw-r--r--dev-python/sh/sh-1.11-r1.ebuild25
-rw-r--r--dev-python/sh/sh-1.11.ebuild25
-rw-r--r--dev-python/sh/sh-1.12.9.ebuild29
5 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 08b31627e8a0..d7ccff4e55c2 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1,3 +1 @@
-DIST sh-1.11.tar.gz 36821 BLAKE2B 30ac7cdb814b307c810190deea54f819d7ad3d134440040c5e0d1718b970331ec4764665f79784acf40b3905da074c19e9dd0338f7306e07d086a583dd058517 SHA512 ccaf178384b5a609c00bb44796a6bec088750414385f19b2d8ffcb93cc8f5ddb6bf82fb966d2bf519651f6efed54258a3c6542a9827d01e6be64af8cb8f86d3d
DIST sh-1.12.14.tar.gz 56861 BLAKE2B dcab86c518fdfdf763053f05a6701fbd0faa76e05d710d6ef709dca89b7527157385ecde355f5f358ba08f7da8e551712732ef43f3074f5568fc7092ed12f014 SHA512 5f2daa2666cf8efe90ba550c8ea5875f2a8812d787597c9d9b933f58feccd192e1ec0ab5695b756bdbfbf9748d106c2045be20838e680b31dac3f778970b5786
-DIST sh-1.12.9.tar.gz 54077 BLAKE2B 6a63a07fe82479388e5d84655d7a22d01fb2be2cb858884f2f69799aa3390443cbf7e6d42b640be6432239ab5d1a0db0b69f1e39bc3e30719dbba78c6fc8f5f0 SHA512 378ebfe148de6d1fb0f6488a42a39570f1fde6bb2d3ce40cbe29a6920e102f4c31d38a686663e52b2968099d85a0b5867e112c5d53ca0a4527a2f2bc9e607d35
diff --git a/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch b/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch
deleted file mode 100644
index 230b16ae5fb1..000000000000
--- a/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/test.py b/test.py
-index 78e00ab..0487594 100644
---- a/test.py
-+++ b/test.py
-@@ -502,7 +502,7 @@ for key in osx_cruft:
- print(os.environ["HERP"] + " " + str(len(os.environ)))
- """ % osx_cruft)
- out = python(py.name, _env=env).strip()
-- self.assertEqual(out, "DERP 1")
-+ self.assertEqual(out, u"DERP 12")
-
- py = create_tmp_test("""
- import os, sys
-@@ -515,7 +515,7 @@ for key in osx_cruft:
- print(sh.HERP + " " + str(len(os.environ)))
- """ % osx_cruft)
- out = python(py.name, _env=env, _cwd=THIS_DIR).strip()
-- self.assertEqual(out, "DERP 1")
-+ self.assertEqual(out, u"DERP 12")
-
-
- def test_which(self):
diff --git a/dev-python/sh/sh-1.11-r1.ebuild b/dev-python/sh/sh-1.11-r1.ebuild
deleted file mode 100644
index 809a920a6c82..000000000000
--- a/dev-python/sh/sh-1.11-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=(python2_7 python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python subprocess interface"
-HOMEPAGE="https://github.com/amoffat/sh"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- ${PYTHON} test.py || die
-}
diff --git a/dev-python/sh/sh-1.11.ebuild b/dev-python/sh/sh-1.11.ebuild
deleted file mode 100644
index a1d927e6592b..000000000000
--- a/dev-python/sh/sh-1.11.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=(python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python subprocess interface"
-HOMEPAGE="https://github.com/amoffat/sh"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- ${PYTHON} test.py || die
-}
diff --git a/dev-python/sh/sh-1.12.9.ebuild b/dev-python/sh/sh-1.12.9.ebuild
deleted file mode 100644
index 4f3271d0964f..000000000000
--- a/dev-python/sh/sh-1.12.9.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python subprocess interface"
-HOMEPAGE="https://github.com/amoffat/sh"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/sh-1.12.9-python2-unicode-tests.patch"
-)
-
-python_test() {
- ${PYTHON} test.py || die
-}