summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/paginate/Manifest1
-rw-r--r--dev-python/paginate/metadata.xml12
-rw-r--r--dev-python/paginate/paginate-0.5.6.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/paginate/Manifest b/dev-python/paginate/Manifest
new file mode 100644
index 000000000000..2289fdca573a
--- /dev/null
+++ b/dev-python/paginate/Manifest
@@ -0,0 +1 @@
+DIST paginate-0.5.6.gh.tar.gz 15567 BLAKE2B c5b60ad43c61a918c618668b345cae82e5e61516aa73130339830db8b8d1d49d271ed24bf9379c570ef8ae9de0844ff8e088820c7e128e1e6e77a03427c06596 SHA512 64d7d1a9952dc8ae5894113c381a9cdca5395477091d794774ed770f1e1dfb6a5d88a7bd07cc4fca0c0c8f708656261f3160b315af6f86ecc5b7f46e1d639150
diff --git a/dev-python/paginate/metadata.xml b/dev-python/paginate/metadata.xml
new file mode 100644
index 000000000000..878328a3af8a
--- /dev/null
+++ b/dev-python/paginate/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">Pylons/paginate</remote-id>
+ <remote-id type="pypi">paginate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/paginate/paginate-0.5.6.ebuild b/dev-python/paginate/paginate-0.5.6.ebuild
new file mode 100644
index 000000000000..46842facb4e6
--- /dev/null
+++ b/dev-python/paginate/paginate-0.5.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Divides large result sets into pages for easier browsing"
+HOMEPAGE="
+ https://github.com/Pylons/paginate/
+ https://pypi.org/project/paginate/
+"
+SRC_URI="
+ https://github.com/Pylons/paginate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest