summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/onion/Manifest1
-rw-r--r--net-libs/onion/files/protos.patch28
-rw-r--r--net-libs/onion/metadata.xml17
-rw-r--r--net-libs/onion/onion-0.8.ebuild71
-rw-r--r--net-libs/onion/onion-9999.ebuild69
-rw-r--r--profiles/package.mask6
6 files changed, 0 insertions, 192 deletions
diff --git a/net-libs/onion/Manifest b/net-libs/onion/Manifest
deleted file mode 100644
index 18f3c70c6226..000000000000
--- a/net-libs/onion/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST onion-0.8.tar.gz 344347 BLAKE2B c43bbbf31d29ccc99d2969c7c8dc9aec8d5e514cc785091e3e0e6d1fc1d5db5f8561d5c2c745b4150a493b607c6c271d669e7ca541f72bf4d8872beeba00b220 SHA512 c40a36346de7dee6e98d0b5c38b5e133606046e29bacb06a0055a361013077ec0f6adb04dfcbf2f4ce0b72317c9ed918573299aed8760f069dcfd7c211a302d7
diff --git a/net-libs/onion/files/protos.patch b/net-libs/onion/files/protos.patch
deleted file mode 100644
index 59050a95c4e6..000000000000
--- a/net-libs/onion/files/protos.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Prototypes do not match, fixes some build failures.
-
-Index: onion-0.8/src/onion/poller_libev.c
-===================================================================
---- onion-0.8.orig/src/onion/poller_libev.c
-+++ onion-0.8/src/onion/poller_libev.c
-@@ -75,7 +75,7 @@ void onion_poller_slot_set_timeout(onion
- el->timeout=timeout_ms;
- }
- /// Sets the polling type: read/write/other. O_POLL_READ | O_POLL_WRITE | O_POLL_OTHER
--void onion_poller_slot_set_type(onion_poller_slot *el, int type){
-+void onion_poller_slot_set_type(onion_poller_slot *el, onion_poller_slot_type_e type){
- el->type=0;
- if (type&O_POLL_READ)
- el->type|=EV_READ;
-Index: onion-0.8/src/onion/poller_libevent.c
-===================================================================
---- onion-0.8.orig/src/onion/poller_libevent.c
-+++ onion-0.8/src/onion/poller_libevent.c
-@@ -77,7 +77,7 @@ void onion_poller_slot_set_timeout(onion
- el->timeout=timeout_ms;
- }
- /// Sets the polling type: read/write/other. O_POLL_READ | O_POLL_WRITE | O_POLL_OTHER
--void onion_poller_slot_set_type(onion_poller_slot *el, int type){
-+void onion_poller_slot_set_type(onion_poller_slot *el, onion_poller_slot_type_e type){
- el->type=EV_PERSIST;
- if (type&O_POLL_READ)
- el->type|=EV_READ;
diff --git a/net-libs/onion/metadata.xml b/net-libs/onion/metadata.xml
deleted file mode 100644
index a9a869a84ec7..000000000000
--- a/net-libs/onion/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>aballier@gentoo.org</email>
- <name>Alexis Ballier</name>
- </maintainer>
- <use>
- <flag name="libev">Use <pkg>dev-libs/libev</pkg> as thread poller instead of Linux's epoll.</flag>
- <flag name="libevent">Use <pkg>dev-libs/libevent</pkg> as thread poller instead of libev or Linux's epoll.</flag>
- <flag name="boehm-gc">Add <pkg>dev-libs/boehm-gc</pkg> support for memory allocations.</flag>
- <flag name="redis">Add support for redis sessions.</flag>
- </use>
- <upstream>
- <remote-id type="github">davidmoreno/onion</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-libs/onion/onion-0.8.ebuild b/net-libs/onion/onion-0.8.ebuild
deleted file mode 100644
index a283da472b81..000000000000
--- a/net-libs/onion/onion-0.8.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/davidmoreno/onion"
-fi
-
-inherit ${SCM} cmake-utils
-
-DESCRIPTION="C library to create simple HTTP servers and Web Applications"
-HOMEPAGE="https://www.coralbits.com/libonion/ https://github.com/davidmoreno/onion"
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/davidmoreno/onion/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-LICENSE="|| ( GPL-2+ Apache-2.0 ) AGPL-3"
-SLOT="0"
-IUSE="
- gnutls pam png jpeg xml systemd sqlite boehm-gc
- test examples cxx libev libevent
- redis
-"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- gnutls? ( net-libs/gnutls dev-libs/libgcrypt:0= )
- pam? ( sys-libs/pam )
- png? ( media-libs/libpng:0= x11-libs/cairo )
- jpeg? ( virtual/jpeg:0 )
- xml? ( dev-libs/libxml2:2 sys-libs/zlib )
- systemd? ( sys-apps/systemd )
- sqlite? ( dev-db/sqlite:3 )
- boehm-gc? ( dev-libs/boehm-gc )
- libev? ( dev-libs/libev )
- !libev? ( libevent? ( dev-libs/libevent ) )
- redis? ( dev-libs/hiredis )
-"
-DEPEND="${RDEPEND}
- test? ( net-misc/curl )
-"
-REQUIRED_USE="test? ( examples )"
-
-PATCHES=( "${FILESDIR}/protos.patch" )
-
-src_configure() {
- use test || echo '' > tests/CMakeLists.txt
- local mycmakeargs=(
- "-DONION_USE_SSL=$(usex gnutls)"
- "-DONION_USE_PAM=$(usex pam)"
- "-DONION_USE_PNG=$(usex png)"
- "-DONION_USE_JPEG=$(usex jpeg)"
- "-DONION_USE_XML2=$(usex xml)"
- "-DONION_USE_SYSTEMD=$(usex systemd)"
- "-DONION_USE_SQLITE3=$(usex sqlite)"
- "-DONION_USE_GC=$(usex boehm-gc)"
- "-DONION_USE_TESTS=$(usex test)"
- "-DONION_EXAMPLES=$(usex examples)"
- "-DONION_USE_BINDINGS_CPP=$(usex cxx)"
- "-DONION_USE_REDIS=$(usex redis)"
- "-DONION_POLLER=$(usex libev libev "$(usex libevent libevent default)")"
- )
- cmake-utils_src_configure
-}
diff --git a/net-libs/onion/onion-9999.ebuild b/net-libs/onion/onion-9999.ebuild
deleted file mode 100644
index 10ba2b76bbf0..000000000000
--- a/net-libs/onion/onion-9999.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/davidmoreno/onion"
-fi
-
-inherit ${SCM} cmake-utils
-
-DESCRIPTION="C library to create simple HTTP servers and Web Applications"
-HOMEPAGE="https://www.coralbits.com/libonion/ https://github.com/davidmoreno/onion"
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/davidmoreno/onion/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-LICENSE="|| ( GPL-2+ Apache-2.0 ) AGPL-3"
-SLOT="0"
-IUSE="
- gnutls pam png jpeg xml systemd sqlite boehm-gc
- test examples cxx libev libevent
- redis
-"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- gnutls? ( net-libs/gnutls dev-libs/libgcrypt:0= )
- pam? ( sys-libs/pam )
- png? ( media-libs/libpng:0= x11-libs/cairo )
- jpeg? ( virtual/jpeg:0 )
- xml? ( dev-libs/libxml2:2 sys-libs/zlib )
- systemd? ( sys-apps/systemd )
- sqlite? ( dev-db/sqlite:3 )
- boehm-gc? ( dev-libs/boehm-gc )
- libev? ( dev-libs/libev )
- !libev? ( libevent? ( dev-libs/libevent ) )
- redis? ( dev-libs/hiredis )
-"
-DEPEND="${RDEPEND}
- test? ( net-misc/curl )
-"
-REQUIRED_USE="test? ( examples )"
-
-src_configure() {
- use test || echo '' > tests/CMakeLists.txt
- local mycmakeargs=(
- "-DONION_USE_SSL=$(usex gnutls)"
- "-DONION_USE_PAM=$(usex pam)"
- "-DONION_USE_PNG=$(usex png)"
- "-DONION_USE_JPEG=$(usex jpeg)"
- "-DONION_USE_XML2=$(usex xml)"
- "-DONION_USE_SYSTEMD=$(usex systemd)"
- "-DONION_USE_SQLITE3=$(usex sqlite)"
- "-DONION_USE_GC=$(usex boehm-gc)"
- "-DONION_USE_TESTS=$(usex test)"
- "-DONION_EXAMPLES=$(usex examples)"
- "-DONION_USE_BINDINGS_CPP=$(usex cxx)"
- "-DONION_USE_REDIS=$(usex redis)"
- "-DONION_POLLER=$(usex libev libev "$(usex libevent libevent default)")"
- )
- cmake-utils_src_configure
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 0491f25cca12..65613c8f534e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -371,12 +371,6 @@ dev-java/piccolo2d
# Removal on 2021-12-16. Bug #819420.
media-video/google2srt
-# Uses EAPI 5, multiple bugs reported, fails to compile,
-# no revdeps, upstream doesn't do regular releases,
-# no other distro is packaging this
-# Removal on 2021-12-16. Bug #770610. Bug #813873. Bug #810682.
-net-libs/onion
-
# Volkmar W. Pogatzki <gentoo@pogatzki.net> (2021-11-15)
# bug #771693 (multiple CVEs).
# Library still needed for bumping dev-java/log4j