summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vkd3d/Manifest1
-rw-r--r--app-emulation/vkd3d/vkd3d-1.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index 99a8cd7b5807..a68ffed16fbf 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1,3 +1,4 @@
DIST vkd3d-1.0.tar.xz 461884 BLAKE2B 4dbd729f9e795d3d81178abc1a8774c0bbe6a5257c96c97acf1e4b4cdb5b7e30c77235e8b8fa57f7db3196caf30c55c3b0c07e2981629dd6177436a3cd117d33 SHA512 55712528688cdedc63049e168b371b470dbb8e31ddc36d8b23b0655f4a061726eb8556b9abf3cb887f6bd21379959aed9fab93ba0fd53813aec413ebec71d615
DIST vkd3d-1.1.tar.xz 487452 BLAKE2B 834ca06d2159a5857dde457f27e541f06624e87633af6aca7445867abc38c56a1da1fe34b6795ffbd6aa73e983ac0e4301402ae35ef8358fa8cc79c12972b11d SHA512 e107612bdca95e998f9d819bdf74e4ffe1b4d400d250ab855c4ebf94b7d3f088b3221591fef03b1c6b8ecb030feb1673f74831bd8bd8edda2989d09a8846b0f7
DIST vkd3d-1.2.tar.xz 611240 BLAKE2B e7ea3f7120ad1092be0239bdc2e6d0dfdfecc3b1c2e7c359c4bfbd8c259f092e041a75a0e896da9a1c6370d5716590711128d31c9e552897b177b300b9a15107 SHA512 ca9d5b11e7770747b78b61f43196b45b7bda8d2dd4f1d76da915f895a04dc28c20499e1e433f5ce17416964fe0f37cdc907e7aa540ec9105afbc8a100094f3e7
+DIST vkd3d-1.4.tar.xz 774920 BLAKE2B c46a71b495fc41658ea493f65ad15aec18202889a9c7925962301cce91f32e197c5850f374331595e4bd267fcbf9836531e733fb5880ddb4936476ddedd19bbc SHA512 58535b57b0b506542f2867e9b1229682f012216b9f8913d2692d4ed64a8113248d66ea710127ec2064baf9511b7f2be7b757dffcaf95a43168d781010d007ddb
diff --git a/app-emulation/vkd3d/vkd3d-1.4.ebuild b/app-emulation/vkd3d/vkd3d-1.4.ebuild
new file mode 100644
index 000000000000..e64cc1a24558
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+fi
+
+#Tests fail: https://bugs.gentoo.org/838655
+RESTRICT="test"
+
+IUSE="spirv-tools"
+RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
+ media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
+ x11-libs/xcb-util:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-wm:=[${MULTILIB_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}