summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/wcslib/Manifest1
-rw-r--r--sci-astronomy/wcslib/wcslib-7.9.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index 05a56ea2a417..f99ebebcd724 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -1,4 +1,3 @@
DIST wcslib-7.11.tar.bz2 2946962 BLAKE2B 7c812f50e3c539da3d58a70acd9128bd957fccd463b0c404c4a55740fb6d7df88f9992d1a2c5c303091dfce91943a6e5bcca73b553354f67c2d522ebb77d6dc3 SHA512 28aa67edad31a8fe27bc8b04e060a17ee75d8fa5e9ec82ccbdb72136558e03d1196151214c9ce4026df88cb807ce2645f5df80bbc479ec91cfa749bf8b9477ec
DIST wcslib-7.3.1.tar.bz2 2434274 BLAKE2B 9789a8eb34fe37c96b52e20efe3c14368499058e5c46aad4853b2be5f32a31df26525ec2c38d0ce87bcb7891b91a3ec3ac537e3c662c716a7c4381f26cd715e4 SHA512 753e0e202fb4250d321c36a0df9cd45ed88697111a06e108bc3e5397ddecc60d460cda2b4d45b5311dd72b88b66d4c70ff150b03e2da46c834b024f15304779b
DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
-DIST wcslib-7.9.tar.bz2 2947112 BLAKE2B 797a1c51dd5b1669faf63c4a509e698f93422d6b4bfc5ace023d75e8e03b2967cc01c6764cca190f07c65b76aec76a740349349561f18f61b870af90bb66ba35 SHA512 72831ced127ad8fce934b43ddde86383273b161316ac078b03dcd8de94b0d6076b625445728695e4c8a9da46cccaa3832038f251922a759f480ef2ad33fd67a1
diff --git a/sci-astronomy/wcslib/wcslib-7.9.ebuild b/sci-astronomy/wcslib/wcslib-7.9.ebuild
deleted file mode 100644
index 8bb41c6f9a45..000000000000
--- a/sci-astronomy/wcslib/wcslib-7.9.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-FORTRAN_NEEDED=fortran
-
-inherit flag-o-matic fortran-2
-
-DESCRIPTION="Astronomical World Coordinate System transformations library"
-HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
-SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
-
-SLOT="0/7"
-LICENSE="LGPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc fortran fits pgplot static-libs +tools"
-
-RDEPEND="
- fits? ( sci-libs/cfitsio:0= )
- pgplot? ( sci-libs/pgplot:0= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- >=sys-devel/flex-2.6.0
- virtual/pkgconfig"
-
-src_configure() {
- # workaround until upstream fix it properly
- append-fflags $(test-flags-FC -fallow-argument-mismatch)
-
- local myconf=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}
- $(use_enable fortran)
- $(use_enable tools utils)
- )
- # hacks because cfitsio and pgplot directories are hard-coded
- if use fits; then
- myconf+=(
- --with-cfitsioinc="${EPREFIX}/usr/include"
- --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
- )
- else
- myconf+=( --without-cfitsio )
- fi
- if use pgplot; then
- myconf+=(
- --with-pgplotinc="${EPREFIX}/usr/include"
- --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
- )
- else
- myconf+=( --without-pgplot )
- fi
- econf "${myconf[@]}"
- sed -i -e 's/COPYING\*//' GNUmakefile || die
-}
-
-src_test() {
- # -j1 to work around a race condition
- emake -j1 check
-}
-
-src_install () {
- default
- # static libs share the same symbols as shared (i.e. compiled with PIC)
- # so they are not compiled twice
- use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
- use doc || rm -r \
- "${ED}"/usr/share/doc/${PF}/html \
- "${ED}"/usr/share/doc/${PF}/*.pdf
-}