summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cppcheck/cppcheck-1.81.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-util/cppcheck/cppcheck-1.81.ebuild b/dev-util/cppcheck/cppcheck-1.81.ebuild
index 2cc7f0445c16..765ecfadc61a 100644
--- a/dev-util/cppcheck/cppcheck-1.81.ebuild
+++ b/dev-util/cppcheck/cppcheck-1.81.ebuild
@@ -16,14 +16,17 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
IUSE="htmlreport pcre qt5"
-RDEPEND="htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
+RDEPEND="
>=dev-libs/tinyxml2-2
+ htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
+ pcre? ( dev-libs/libpcre )
qt5? ( dev-qt/qtgui:5 )
- pcre? ( dev-libs/libpcre )"
+"
DEPEND="${RDEPEND}
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
src_prepare() {
append-cxxflags -std=c++0x