summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-containers/buildah/Manifest3
-rw-r--r--app-containers/buildah/buildah-1.23.1-r1.ebuild51
-rw-r--r--app-containers/buildah/buildah-1.24.2.ebuild51
-rw-r--r--app-containers/buildah/buildah-1.24.3.ebuild51
4 files changed, 0 insertions, 156 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 75f5f2e0efaa..30a392c4df8a 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,4 +1 @@
-DIST buildah-1.23.1.tar.gz 11872323 BLAKE2B 6e4cffd11177bca6c3e86cd3372fc7bf295b23559b7478a679ea2bea022c149b5ea058224f0a156df1b9511905795c44ed5e988ec68ca834dd80d0c198543d5f SHA512 2ceb6df5adb671483557bb03937df583857d99c116be5d44aae533c155f560d5d454bebf25908ac02bb85e4c2ba31533adb99f0946ecc4f4830977c14f324b6f
-DIST buildah-1.24.2.tar.gz 14184511 BLAKE2B ad9ee6f332a89038368d9a5d86198f1dfa9cf99a970e85ccf3b272294fc262c68c37004131971b0ec148e999e4d8f192f4955e71673f05188110407949eb3546 SHA512 dada2b65340386355aba3980c38d9be0f43d5c3f9316c6f8e713f299ee2b975e409c1b3a785daa52b59e688c3a9c9016c43d9b0a6443d4a9453aababc0a8afa0
-DIST buildah-1.24.3.tar.gz 14189867 BLAKE2B 18b6eaf0ba54c310c8b946e4763f3b930ff4e0bfd85333767b8baa3320df1f43937d4742404d11de51c6386a12521e3045770d1d19406c163accd9cccc500961 SHA512 74fa6073ddf6b641700f758435d4558fc2d61691172107572dfac3d723f986aa0faf7bb5b5d1e2bd6bed5d118cbed3c78b6faf96972770b304fa28fd363b4700
DIST buildah-1.25.1.tar.gz 14212065 BLAKE2B ec4f668654011f1b93745e1a1d575fdda0cd5f4d6f9f7f7b3106c24aa7d405951ecd645a54c2dd5a3ad2695069e66ad847bdb15f0e73a9c7efba2a7e283d4f58 SHA512 628f8095eb4488ae2be06a2a92de85dde4f3841e8ed9882132c119f27b0c93f26ba10f5dd259d63654b90539d762f6c1973d460f073c0b2450ac5d9582a6a68d
diff --git a/app-containers/buildah/buildah-1.23.1-r1.ebuild b/app-containers/buildah/buildah-1.23.1-r1.ebuild
deleted file mode 100644
index 7d3899b67e1b..000000000000
--- a/app-containers/buildah/buildah-1.23.1-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-GIT_COMMIT=d9a41b85
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64"
-IUSE="selinux"
-
-RDEPEND="app-crypt/gpgme:=
- app-containers/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-
-RESTRICT+=" test"
-
-src_prepare() {
- default
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
- sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
-}
-
-src_compile() {
- emake GIT_COMMIT=${GIT_COMMIT} all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin bin/{${PN},imgtype}
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- emake test-unit
-}
diff --git a/app-containers/buildah/buildah-1.24.2.ebuild b/app-containers/buildah/buildah-1.24.2.ebuild
deleted file mode 100644
index 11751a5ccd2c..000000000000
--- a/app-containers/buildah/buildah-1.24.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-GIT_COMMIT=ce608bce
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="selinux"
-
-RDEPEND="app-crypt/gpgme:=
- app-containers/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-
-RESTRICT+=" test"
-
-src_prepare() {
- default
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
- sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
-}
-
-src_compile() {
- emake GIT_COMMIT=${GIT_COMMIT} all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin bin/{${PN},imgtype}
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- emake test-unit
-}
diff --git a/app-containers/buildah/buildah-1.24.3.ebuild b/app-containers/buildah/buildah-1.24.3.ebuild
deleted file mode 100644
index 9f76a531fd27..000000000000
--- a/app-containers/buildah/buildah-1.24.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-GIT_COMMIT=8a645e9a
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="selinux"
-
-RDEPEND="app-crypt/gpgme:=
- app-containers/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-
-RESTRICT+=" test"
-
-src_prepare() {
- default
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
- sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
-}
-
-src_compile() {
- emake GIT_COMMIT=${GIT_COMMIT} all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin bin/{${PN},imgtype}
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- emake test-unit
-}