summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/linux-info.eclass17
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.36-r1.ebuild (renamed from media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild)4
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-9999.ebuild4
-rw-r--r--media-libs/libcaca/libcaca-0.99_beta19-r5.ebuild (renamed from media-libs/libcaca/libcaca-0.99_beta19-r1.ebuild)8
-rw-r--r--media-libs/libcaca/libcaca-0.99_beta19-r6.ebuild (renamed from media-libs/libcaca/libcaca-0.99_beta19-r3.ebuild)4
-rw-r--r--media-libs/libcaca/libcaca-0.99_beta19-r7.ebuild (renamed from media-libs/libcaca/libcaca-0.99_beta19-r4.ebuild)4
-rw-r--r--net-p2p/litecoind/litecoind-0.10.4.0-r2.ebuild2
-rw-r--r--net-p2p/litecoind/litecoind-0.18.1-r1.ebuild (renamed from net-p2p/litecoind/litecoind-0.18.1.ebuild)2
8 files changed, 27 insertions, 18 deletions
diff --git a/eclass/linux-info.eclass b/eclass/linux-info.eclass
index 55f38af0ffd8..861123e0e8b7 100644
--- a/eclass/linux-info.eclass
+++ b/eclass/linux-info.eclass
@@ -33,8 +33,10 @@
# @DESCRIPTION:
# A string containing the directory of the target kernel sources. The default value is
# "/usr/src/linux"
+KERNEL_DIR="${KERNEL_DIR:-${ROOT%/}/usr/src/linux}"
# @ECLASS-VARIABLE: CONFIG_CHECK
+# @DEFAULT_UNSET
# @DESCRIPTION:
# A string containing a list of .config options to check for before
# proceeding with the install.
@@ -57,6 +59,7 @@
# sources.
# @ECLASS-VARIABLE: ERROR_<CFG>
+# @DEFAULT_UNSET
# @DESCRIPTION:
# A string containing the error message to display when the check against CONFIG_CHECK
# fails. <CFG> should reference the appropriate option used in CONFIG_CHECK.
@@ -64,6 +67,7 @@
# e.g.: ERROR_MTRR="MTRR exists in the .config but shouldn't!!"
# @ECLASS-VARIABLE: KBUILD_OUTPUT
+# @DEFAULT_UNSET
# @DESCRIPTION:
# A string passed on commandline, or set from the kernel makefile. It contains the directory
# which is to be used as the kernel object directory.
@@ -72,35 +76,43 @@
# set by hand. These are as follows:
# @ECLASS-VARIABLE: KV_FULL
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's a string containing the full kernel version. ie: 2.6.9-gentoo-johnm-r1
# @ECLASS-VARIABLE: KV_MAJOR
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's an integer containing the kernel major version. ie: 2
# @ECLASS-VARIABLE: KV_MINOR
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's an integer containing the kernel minor version. ie: 6
# @ECLASS-VARIABLE: KV_PATCH
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's an integer containing the kernel patch version. ie: 9
# @ECLASS-VARIABLE: KV_EXTRA
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's a string containing the kernel EXTRAVERSION. ie: -gentoo
# @ECLASS-VARIABLE: KV_LOCAL
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's a string containing the kernel LOCALVERSION concatenation. ie: -johnm
# @ECLASS-VARIABLE: KV_DIR
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's a string containing the kernel source directory, will be null if
# KERNEL_DIR is invalid.
# @ECLASS-VARIABLE: KV_OUT_DIR
+# @INTERNAL
# @DESCRIPTION:
# A read-only variable. It's a string containing the kernel object directory, will be KV_DIR unless
# KBUILD_OUTPUT is used. This should be used for referencing .config.
@@ -113,11 +125,6 @@ EXPORT_FUNCTIONS pkg_setup
IUSE="kernel_linux"
-# Overwritable environment Var's
-# ---------------------------------------
-KERNEL_DIR="${KERNEL_DIR:-${ROOT%/}/usr/src/linux}"
-
-
# Bug fixes
# fix to bug #75034
case ${ARCH} in
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.36-r1.ebuild
index 22f9ab4a3d52..14c616c7050f 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.36-r1.ebuild
@@ -20,7 +20,7 @@ else
KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
-IUSE="bzip2 +cxx debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma
+IUSE="bzip2 debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma
openmp perl png postscript q16 q32 static-libs svg threads tiff truetype
webp wmf X zlib"
@@ -83,7 +83,7 @@ src_configure() {
$(use_with dynamic-loading modules)
--with-quantum-depth=${depth}
--without-frozenpaths
- $(use_with cxx magick-plus-plus)
+ --with-magick-plus-plus
$(use_with perl)
--with-perl-options=INSTALLDIRS=vendor
$(use_with bzip2 bzlib)
diff --git a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
index 71a6c9e5bbc5..c3b910007501 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
@@ -20,7 +20,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
-IUSE="bzip2 +cxx debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma
+IUSE="bzip2 debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma
openmp perl png postscript q16 q32 static-libs svg threads tiff truetype
webp wmf X zlib"
@@ -83,7 +83,7 @@ src_configure() {
$(use_with dynamic-loading modules)
--with-quantum-depth=${depth}
--without-frozenpaths
- $(use_with cxx magick-plus-plus)
+ --with-magick-plus-plus
$(use_with perl)
--with-perl-options=INSTALLDIRS=vendor
$(use_with bzip2 bzlib)
diff --git a/media-libs/libcaca/libcaca-0.99_beta19-r1.ebuild b/media-libs/libcaca/libcaca-0.99_beta19-r5.ebuild
index a7e21adb2add..1b649c631608 100644
--- a/media-libs/libcaca/libcaca-0.99_beta19-r1.ebuild
+++ b/media-libs/libcaca/libcaca-0.99_beta19-r5.ebuild
@@ -15,7 +15,7 @@ SRC_URI="http://libcaca.zoy.org/files/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2 ISC LGPL-2.1 WTFPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="cxx doc imlib java mono ncurses opengl ruby slang static-libs test truetype X"
+IUSE="doc imlib java mono ncurses opengl ruby slang static-libs test truetype X"
RESTRICT="!test? ( test )"
REQUIRED_USE=""
# ruby? ( ruby_targets_${USE_RUBY} )
@@ -112,9 +112,11 @@ multilib_src_configure() {
$(use_enable static-libs static) \
$(use_enable slang) \
$(use_enable ncurses) \
- $(use_enable X x11) $(use_with X x) --x-libraries=/usr/$(get_libdir) \
+ $(use_enable X x11) \
+ $(use_with X x) \
+ --x-libraries=/usr/$(get_libdir) \
$(use_enable opengl gl) \
- $(use_enable cxx) \
+ --enable-cxx \
$(use_enable imlib imlib2) \
$(use_enable test cppunit) \
$(multilib_native_use_enable java) \
diff --git a/media-libs/libcaca/libcaca-0.99_beta19-r3.ebuild b/media-libs/libcaca/libcaca-0.99_beta19-r6.ebuild
index 9e2445342374..a6e06f3e038e 100644
--- a/media-libs/libcaca/libcaca-0.99_beta19-r3.ebuild
+++ b/media-libs/libcaca/libcaca-0.99_beta19-r6.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 ISC LGPL-2.1 WTFPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="cxx doc imlib java mono ncurses opengl ruby slang static-libs test truetype X"
+IUSE="doc imlib java mono ncurses opengl ruby slang static-libs test truetype X"
RESTRICT="!test? ( test )"
# ruby? ( ruby_targets_${USE_RUBY} )
@@ -130,7 +130,7 @@ multilib_src_configure() {
$(use_with X x)
--x-libraries=/usr/$(get_libdir)
$(use_enable opengl gl)
- $(use_enable cxx)
+ --enable-cxx
$(use_enable imlib imlib2)
$(use_enable test cppunit)
$(multilib_native_use_enable java)
diff --git a/media-libs/libcaca/libcaca-0.99_beta19-r4.ebuild b/media-libs/libcaca/libcaca-0.99_beta19-r7.ebuild
index f0eece5142c7..bc7b204dd360 100644
--- a/media-libs/libcaca/libcaca-0.99_beta19-r4.ebuild
+++ b/media-libs/libcaca/libcaca-0.99_beta19-r7.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 ISC LGPL-2.1 WTFPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="cxx doc imlib java mono ncurses opengl ruby slang static-libs test truetype X"
+IUSE="doc imlib java mono ncurses opengl ruby slang static-libs test truetype X"
RESTRICT="!test? ( test )"
# ruby? ( ruby_targets_${USE_RUBY} )
@@ -139,7 +139,7 @@ multilib_src_configure() {
$(use_with X x)
--x-libraries=/usr/$(get_libdir)
$(use_enable opengl gl)
- $(use_enable cxx)
+ --enable-cxx
$(use_enable imlib imlib2)
$(use_enable test cppunit)
$(multilib_native_use_enable java)
diff --git a/net-p2p/litecoind/litecoind-0.10.4.0-r2.ebuild b/net-p2p/litecoind/litecoind-0.10.4.0-r2.ebuild
index 3e3d54946880..4baece7f884c 100644
--- a/net-p2p/litecoind/litecoind-0.10.4.0-r2.ebuild
+++ b/net-p2p/litecoind/litecoind-0.10.4.0-r2.ebuild
@@ -95,7 +95,7 @@ src_install() {
fperms 700 /var/lib/litecoin
fowners litecoin:litecoin /var/lib/litecoin/
fowners litecoin:litecoin /var/lib/litecoin/.litecoin
- dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
+ dosym ../../../../etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
dodoc doc/README.md doc/release-notes.md
newman contrib/debian/manpages/bitcoind.1 litecoind.1
diff --git a/net-p2p/litecoind/litecoind-0.18.1.ebuild b/net-p2p/litecoind/litecoind-0.18.1-r1.ebuild
index 03ac46dc52de..9bc5f8cbf0fc 100644
--- a/net-p2p/litecoind/litecoind-0.18.1.ebuild
+++ b/net-p2p/litecoind/litecoind-0.18.1-r1.ebuild
@@ -78,7 +78,7 @@ src_install() {
fperms 700 /var/lib/litecoin
fowners litecoin:litecoin /var/lib/litecoin/
fowners litecoin:litecoin /var/lib/litecoin/.litecoin
- dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
+ dosym ../../../../etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
dodoc doc/README.md doc/release-notes.md