summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/swift-mode/Manifest1
-rw-r--r--app-emacs/swift-mode/swift-mode-9.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/swift-mode/Manifest b/app-emacs/swift-mode/Manifest
index 93463ec1b857..7bd50c63ad4f 100644
--- a/app-emacs/swift-mode/Manifest
+++ b/app-emacs/swift-mode/Manifest
@@ -1 +1,2 @@
DIST swift-mode-9.1.0.tar.gz 228848 BLAKE2B 8da59aacc7b2f49b3156c5c22b92c7574df96657aeb95154b82551008f883f676935cabc3ddca86da8ab6c0364ab6ab9c963025f0fb361652179ab655076cf24 SHA512 ba06f67695cf10a3b78b29d5e375d8c76fb2f19cb2b6420d63332502062a461cc5e836f54dcc56f10cef3e6f3ed38c8803332c94372f2fbbdc681dc7a0fafbe9
+DIST swift-mode-9.2.0.tar.gz 229216 BLAKE2B 5c19f919919f41ad725f1c5434022eed0be3f2b64b8165d6a9eb84b8a5467cde620f610cab4e303ef00a731f7327512caf1f1b746ab1fbe452534f1577ba6bf6 SHA512 1761639aa7281bbadef68f56dd4276799a72d03c5bb9dafc3fcd7e9f4b819f288e1b7727e3a0839862df7cf6e649549fc4b1be0f922f8a508d9c526f67d92c97
diff --git a/app-emacs/swift-mode/swift-mode-9.2.0.ebuild b/app-emacs/swift-mode/swift-mode-9.2.0.ebuild
new file mode 100644
index 000000000000..c996fb0680cb
--- /dev/null
+++ b/app-emacs/swift-mode/swift-mode-9.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs support for Apple's Swift programming language"
+HOMEPAGE="https://github.com/swift-emacs/swift-mode/"
+SRC_URI="https://github.com/swift-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DOCS=( README.md CONTRIBUTING.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} \
+ -L . -L test \
+ -l test/swift-mode-test.el \
+ -f swift-mode:run-test || die "tests failed"
+}