summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild39
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild39
2 files changed, 48 insertions, 30 deletions
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
index 63d6cf51df70..f4f8860efa36 100644
--- a/app-i18n/opencc/opencc-1.0.5.ebuild
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2010-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit cmake-utils
@@ -9,14 +9,15 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
-else
- inherit vcs-snapshot
-
- SRC_URI="https://github.com/BYVoid/${PN^^[oc]}/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
fi
-DESCRIPTION="Libraries for conversion between Traditional and Simplified Chinese"
+DESCRIPTION="Library for conversion between Traditional and Simplified Chinese characters"
HOMEPAGE="https://github.com/BYVoid/OpenCC"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
LICENSE="Apache-2.0"
SLOT="0/2"
@@ -24,25 +25,33 @@ KEYWORDS="amd64 arm64 hppa ppc ppc64 sparc x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/OpenCC-ver.${PV}"
+fi
-DOCS="AUTHORS *.md"
PATCHES=(
- "${FILESDIR}"/${PN}-test.patch
- "${FILESDIR}"/${PN}-stop-copy.patch
+ "${FILESDIR}/${PN}-test.patch"
+ "${FILESDIR}/${PN}-stop-copy.patch"
)
-src_prepare() {
- sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt
+DOCS=(AUTHORS NEWS.md README.md)
+src_prepare() {
cmake-utils_src_prepare
+
+ sed -e "s:\${DIR_SHARE_OPENCC}/doc:share/doc/${PF}:" -i doc/CMakeLists.txt || die
}
src_configure() {
local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_DOCUMENTATION=$(usex doc ON OFF)
-DBUILD_SHARED_LIBS=ON
- -DENABLE_GTEST=$(usex test)
+ -DENABLE_GTEST=$(usex test ON OFF)
)
+
cmake-utils_src_configure
}
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
index 0b47d39a633a..ea43829ed2f6 100644
--- a/app-i18n/opencc/opencc-9999.ebuild
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2010-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit cmake-utils
@@ -9,14 +9,15 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
-else
- inherit vcs-snapshot
-
- SRC_URI="https://github.com/BYVoid/${PN^^[oc]}/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
fi
-DESCRIPTION="Libraries for conversion between Traditional and Simplified Chinese"
+DESCRIPTION="Library for conversion between Traditional and Simplified Chinese characters"
HOMEPAGE="https://github.com/BYVoid/OpenCC"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
LICENSE="Apache-2.0"
SLOT="0/2"
@@ -24,25 +25,33 @@ KEYWORDS=""
IUSE="doc test"
RESTRICT="!test? ( test )"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/OpenCC-ver.${PV}"
+fi
-DOCS="AUTHORS *.md"
PATCHES=(
- "${FILESDIR}"/${PN}-test.patch
- "${FILESDIR}"/${PN}-stop-copy.patch
+ "${FILESDIR}/${PN}-test.patch"
+ "${FILESDIR}/${PN}-stop-copy.patch"
)
-src_prepare() {
- sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt
+DOCS=(AUTHORS NEWS.md README.md)
+src_prepare() {
cmake-utils_src_prepare
+
+ sed -e "s:\${DIR_SHARE_OPENCC}/doc:share/doc/${PF}:" -i doc/CMakeLists.txt || die
}
src_configure() {
local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_DOCUMENTATION=$(usex doc ON OFF)
-DBUILD_SHARED_LIBS=ON
- -DENABLE_GTEST=$(usex test)
+ -DENABLE_GTEST=$(usex test ON OFF)
)
+
cmake-utils_src_configure
}