summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/setools/setools-9999.ebuild')
-rw-r--r--app-admin/setools/setools-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 0ce34473cb2a..052075285d71 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,30 +1,30 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
DESCRIPTION="Policy Analysis Tools for SELinux"
HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
S="${WORKDIR}/${P}"
else
SRC_URI="https://github.com/SELinuxProject/setools/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
S="${WORKDIR}/${PN}"
fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="test X"
+IUSE="gui test"
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
@@ -32,13 +32,15 @@ RDEPEND="${PYTHON_DEPS}
dev-python/setuptools[${PYTHON_USEDEP}]
>=sys-libs/libsepol-3.2:=
>=sys-libs/libselinux-3.2:=
- X? (
- dev-python/PyQt6[gui,widgets,${PYTHON_USEDEP}]
+ gui? (
+ dev-python/pyqt6[gui,widgets,${PYTHON_USEDEP}]
dev-python/pygraphviz[${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}"
BDEPEND=">=dev-python/cython-0.29.14[${PYTHON_USEDEP}]
test? (
+ dev-python/pyqt6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
sys-apps/checkpolicy
)"
@@ -48,7 +50,7 @@ python_prepare_all() {
sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
die "failed to set lib_dirs"
- use X || PATCHES+=( "${FILESDIR}"/setools-4.4.2-remove-gui.patch )
+ use gui || PATCHES+=( "${FILESDIR}"/${PN}-4.5.1-remove-gui.patch )
distutils-r1_python_prepare_all
}