summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild')
-rw-r--r--dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild b/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild
new file mode 100644
index 000000000000..11093dfac280
--- /dev/null
+++ b/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+ANT_TASK_DEPNAME=""
+ANT_TASK_DISABLE_VM_DEPS="true"
+
+inherit ant-tasks
+
+DESCRIPTION="Formerly Ant's optional tasks w/o external deps, now compat empty jar"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Dependency needed for jar.
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ # The classes were moved to ant-core in 1.8.2, this is just for compatibility.
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar . || die
+}
+
+pkg_postinst() {
+ elog "Upstream has removed ant-nodeps.jar as of 1.8.2 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}