summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-installer/opam-installer-2.2.1.ebuild')
-rw-r--r--dev-ml/opam-installer/opam-installer-2.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/opam-installer-2.2.1.ebuild b/dev-ml/opam-installer/opam-installer-2.2.1.ebuild
new file mode 100644
index 000000000000..f9d4c4943e8b
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/jsonm:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ dev-ml/ocaml-sha:=[ocamlopt?]
+ ~dev-ml/opam-common-${PV}:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/swhid_core:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/uchar:=[ocamlopt?]
+ dev-ml/uutf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ${PN}
+}
+
+src_install() {
+ dune-install ${PN}
+ mv "${ED}"/usr/share/doc/${PF}/${PN}/* \
+ "${ED}"/usr/share/doc/${PF} || die
+}