summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/IO-CaptureOutput')
-rw-r--r--dev-perl/IO-CaptureOutput/IO-CaptureOutput-1.110.400.ebuild31
-rw-r--r--dev-perl/IO-CaptureOutput/Manifest1
-rw-r--r--dev-perl/IO-CaptureOutput/metadata.xml5
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/IO-CaptureOutput/IO-CaptureOutput-1.110.400.ebuild b/dev-perl/IO-CaptureOutput/IO-CaptureOutput-1.110.400.ebuild
new file mode 100644
index 000000000000..3dd5d777d9ec
--- /dev/null
+++ b/dev-perl/IO-CaptureOutput/IO-CaptureOutput-1.110.400.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DAGOLDEN
+MODULE_VERSION=1.1104
+inherit perl-module
+
+DESCRIPTION="Capture STDOUT and STDERR from Perl code, subprocesses or XS"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ >=virtual/perl-File-Temp-0.160.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-File-Spec-3.270.0
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.620.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/IO-CaptureOutput/Manifest b/dev-perl/IO-CaptureOutput/Manifest
new file mode 100644
index 000000000000..6110f1d1e355
--- /dev/null
+++ b/dev-perl/IO-CaptureOutput/Manifest
@@ -0,0 +1 @@
+DIST IO-CaptureOutput-1.1104.tar.gz 27651 SHA256 fcc732fcb438f97a72b30e8c7796484bef2562e374553b207028e2fbf73f8330 SHA512 5694635c91e4dd11279c33fb9d58e2eb27014f4ea0a976e62c23505524e3d37264aab6d6b1cfe5d925e123d6aa240e574dbc4f489c6c1007da09631368af94f5 WHIRLPOOL b18f9eb5a88bf655c7ce448cd6b164885ee8e4a0da44e572a9c266c4295c3a9049958898ef74eda631e54d117de8b5a707fa10788e7ee94d442658c708afe5e1
diff --git a/dev-perl/IO-CaptureOutput/metadata.xml b/dev-perl/IO-CaptureOutput/metadata.xml
new file mode 100644
index 000000000000..708bcbd30056
--- /dev/null
+++ b/dev-perl/IO-CaptureOutput/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>perl</herd>
+</pkgmetadata>