summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild')
-rw-r--r--dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
new file mode 100644
index 000000000000..639a6a6a8471
--- /dev/null
+++ b/dev-perl/Net-Patricia/Net-Patricia-1.220.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GRUBER
+MODULE_VERSION=1.22
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Patricia Trie perl module for fast IP address lookups"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6"
+
+RDEPEND="dev-perl/Net-CIDR-Lite
+ ipv6? (
+ dev-perl/Socket6
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
+
+#SRC_TEST="do"