summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-envs')
-rw-r--r--dev-python/jaraco-envs/Manifest1
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jaraco-envs/Manifest b/dev-python/jaraco-envs/Manifest
index 2132816a3a49..1027c520dbc8 100644
--- a/dev-python/jaraco-envs/Manifest
+++ b/dev-python/jaraco-envs/Manifest
@@ -1 +1,2 @@
DIST jaraco.envs-2.1.0.tar.gz 10207 BLAKE2B 80a2888ab655b1c524a80d33f8c15b08257b2d4415bbc30ce0d60f8f4a019f8f1e0f05cefcb2b4f64688a0e6ccabb227c5824c27c6f63f6ecb926e0dc1ad208c SHA512 e9cbe17a86bdcda17ba1378373d729d850a2a4b0d0924a059dea0fc448964d55522da99a27c507475973b5d3cbc822ca184ebdb877207019f1daf6d5fffcb7d7
+DIST jaraco.envs-2.1.1.tar.gz 10190 BLAKE2B 3b191549fe8a5cee1a964559f7ecba8305ac22cc1980191c7fd967a8fb5eac7c81cd8a2752566e2d0e820a9d089422d11fc5529f56d4266cae411ce13e304bb8 SHA512 c71aab9748cfa31c27bb7899117e15d2836851a47a76b638177facc89e894dfa2c4168da2d5b1873b1eeed0d785d23137e56e198f92fb83deb26aab38e342ad2
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild
new file mode 100644
index 000000000000..a044f6645ec7
--- /dev/null
+++ b/dev-python/jaraco-envs/jaraco-envs-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Classes for orchestrating Python (virtual) environments."
+HOMEPAGE="https://github.com/jaraco/jaraco.envs"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/path-py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' 'python3_[67]')"
+# toml is required by setuptools_scm
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+# there are no actual tests, just flake8 etc
+RESTRICT="test"