summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyclamd/pyclamd-0.4.0-r5.ebuild')
-rw-r--r--dev-python/pyclamd/pyclamd-0.4.0-r5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyclamd/pyclamd-0.4.0-r5.ebuild b/dev-python/pyclamd/pyclamd-0.4.0-r5.ebuild
new file mode 100644
index 000000000000..89d623d69615
--- /dev/null
+++ b/dev-python/pyclamd/pyclamd-0.4.0-r5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=pyClamd
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to Clamd (ClamAV daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Tests need clamd running and we cannot rely on that being
+# true during build
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${P}-remove-obsolete-bugtrack_url.diff" )