summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyqt6-sip')
-rw-r--r--dev-python/pyqt6-sip/Manifest1
-rw-r--r--dev-python/pyqt6-sip/metadata.xml12
-rw-r--r--dev-python/pyqt6-sip/pyqt6-sip-13.8.0.ebuild23
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyqt6-sip/Manifest b/dev-python/pyqt6-sip/Manifest
new file mode 100644
index 000000000000..04c1ad8f8c0f
--- /dev/null
+++ b/dev-python/pyqt6-sip/Manifest
@@ -0,0 +1 @@
+DIST PyQt6_sip-13.8.0.tar.gz 92264 BLAKE2B b44ba35c3209b3a49fccf0e4634af8a410b1531d0dd74fc665d7da9780f4e32baf18fbba80eb9635a96442c1c91295dc10e0388194d1e169d300e0e1b37d18cd SHA512 6947690e61fe65a21f61d034ae9de7b7adb001c59a4a362933c5441648fe27140b43666efa73f981b138cfc73fac72777bb7318b98accc3c7f808687e3fc5d81
diff --git a/dev-python/pyqt6-sip/metadata.xml b/dev-python/pyqt6-sip/metadata.xml
new file mode 100644
index 000000000000..c37952e6b29f
--- /dev/null
+++ b/dev-python/pyqt6-sip/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Python-SIP/sip/issues</bugs-to>
+ <remote-id type="pypi">PyQt6-sip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyqt6-sip/pyqt6-sip-13.8.0.ebuild b/dev-python/pyqt6-sip/pyqt6-sip-13.8.0.ebuild
new file mode 100644
index 000000000000..4b3eeeed1788
--- /dev/null
+++ b/dev-python/pyqt6-sip/pyqt6-sip-13.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+# actually, it's PyQt6-sip but upstream uses incorrect sdist name
+PYPI_PN=PyQt6_sip
+# keep compat in sync with PyQt6 or else it confuses some revdeps
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip module support for PyQt6"
+# note that PyQt6-sip is currently not on github, but this is the
+# homepage listed upstream as of the writing of this
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"