summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/requests-cache-1.1.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/requests-cache/requests-cache-1.1.0.ebuild b/dev-python/requests-cache/requests-cache-1.1.0.ebuild
index 0b4386374d3e..8495284f8b9b 100644
--- a/dev-python/requests-cache/requests-cache-1.1.0.ebuild
+++ b/dev-python/requests-cache/requests-cache-1.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 optfeature
@@ -61,6 +61,16 @@ python_test() {
tests/integration/test_upgrade.py::test_version_upgrade
)
+ case ${EPYTHON} in
+ python3.12)
+ # https://github.com/requests-cache/requests-cache/issues/845
+ EPYTEST_DESELECT+=(
+ tests/integration/test_memory.py::TestMemoryCache::test_response_no_duplicate_read
+ tests/integration/test_sqlite.py::TestSQLiteCache::test_concurrency
+ )
+ ;;
+ esac
+
local -x USE_PYTEST_HTTPBIN=true
epytest
}