summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest1
-rw-r--r--dev-ruby/kramdown/kramdown-2.5.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index 6d06c2bd7b17..1e9cbcba2c6c 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1 +1,2 @@
DIST kramdown-2.4.0.gem 122368 BLAKE2B 86b1232583dc88f8a576fb17e3e2ee756f109700634783815e8ba1f722dd8c872f2f6a978d33e1970814530090665eba3693206e57d3f274bb39655a7ac2d208 SHA512 8e52c5cc53d2f0085e30188aa7bf67f92dfe7f0801297c6a45293cca307e3442baa06443638c1161dad4a4aa332cbc5b4f9b6281ba4c6346122a9fff5a3743c7
+DIST kramdown-2.5.1.gem 128512 BLAKE2B 6965ec9da5f445644b624b035678003782177ed899e4f8db33ed6548a1e15baa3fec2dce151f458da093e852277b588f598bdfb8b352c340e9a7d2e620b1c58c SHA512 751678bf0ce30c5c89a6d21ff0b3a7b9e2ffd5c95dcaefc348d16663cc76602de827efe657b86b9456a6b8dfec04f9f3768c99678fddaac0ffad8f6051738f20
diff --git a/dev-ruby/kramdown/kramdown-2.5.1.ebuild b/dev-ruby/kramdown/kramdown-2.5.1.ebuild
new file mode 100644
index 000000000000..f8dc0ef058fd
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-2.5.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="https://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos"
+IUSE="latex unicode"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND="${LATEX_DEPS}"
+DEPEND="test? (
+ ${LATEX_DEPS}
+ >=app-text/htmltidy-5.0.0
+)"
+
+ruby_add_rdepend "
+ >=dev-ruby/rexml-3.3.9
+ >=dev-ruby/rouge-3.26.0:2
+ unicode? ( >=dev-ruby/stringex-1.5.1 )
+"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ if ! use unicode; then
+ rm -f test/testcases/block/04_header/with_auto_ids.* || die
+ fi
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}