summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pathutil/pathutil-0.16.2.ebuild')
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ruby/pathutil/pathutil-0.16.2.ebuild b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
index de1ff3557b23..8b97ba38abb5 100644
--- a/dev-ruby/pathutil/pathutil-0.16.2.ebuild
+++ b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -24,6 +24,8 @@ IUSE=""
ruby_add_rdepend ">=dev-ruby/forwardable-extended-2.6
<dev-ruby/forwardable-extended-3"
+ruby_add_bdepend "test? ( dev-ruby/safe_yaml )"
+
all_ruby_prepare() {
sed -i -e '/\(coverage\|luna\|rspec\/helpers\)/ s:^:#:' \
-e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json"' \