summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/dbuskit/dbuskit-0.1.ebuild')
-rw-r--r--gnustep-libs/dbuskit/dbuskit-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnustep-libs/dbuskit/dbuskit-0.1.ebuild b/gnustep-libs/dbuskit/dbuskit-0.1.ebuild
new file mode 100644
index 000000000000..a0698e2e1b0f
--- /dev/null
+++ b/gnustep-libs/dbuskit/dbuskit-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools gnustep-2
+
+DESCRIPTION="framework that interfaces Objective-C applications with the D-Bus IPC service"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/dbus-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ # Bug 410697
+ sed -e "s#ObjectiveC2/runtime.h#ObjectiveC2/objc/runtime.h#" \
+ -i configure.ac || die "ObjectiveC2 runtime sed failed"
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e "/SUBPROJECTS/s/Documentation//" GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ eautoreconf
+}