summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-recorder/Manifest1
-rw-r--r--gui-apps/wf-recorder/files/wf-recorder-0.5.0-fix-build-with-no-audio.patch48
-rw-r--r--gui-apps/wf-recorder/wf-recorder-0.5.0.ebuild46
3 files changed, 95 insertions, 0 deletions
diff --git a/gui-apps/wf-recorder/Manifest b/gui-apps/wf-recorder/Manifest
index 6a86d06fdba2..99533c30fa67 100644
--- a/gui-apps/wf-recorder/Manifest
+++ b/gui-apps/wf-recorder/Manifest
@@ -1,2 +1,3 @@
DIST wf-recorder-0.3.0.tar.xz 19888 BLAKE2B 52b7cbe8ad77d3756f91cad0c0642548b439f3465be8152d9cc1175f55d608df8bbd9f21e82b18099fba59d39389012e023e7dc39a0ae061eed13aece99c058a SHA512 6c8a069c923a342441ab5ebce2cf8ec727b75f474c2843d0fa49b69b3e5ef4498bc0548573409203e704a84a72ebec5523f89459a144679bf1d9d5bf6e514b60
DIST wf-recorder-0.4.1.tar.xz 26184 BLAKE2B 87110d3fb8629b5cdfc2c4b50da56d19630b97ffb7e46a555099c8fca263bd1bd87fb03a497fbb5e5ac0022b31bb5c93dc4ea29785de33dd7f2adc8db74f7db2 SHA512 c97b3a0570aa5496d93b88549db6cd682e80c1497bbd6e999ab6b35f2f13adc7af167c22517fa35eab5d3021439001d0e7cfe2ee75a2ba99b9aa6953beb56aa0
+DIST wf-recorder-0.5.0.tar.xz 28348 BLAKE2B 2e0f55c61212e863782b176261d4c382cd01ec30746a2b9b35c4e14d01c57358180f63cdd91eba0caecd5dac1eb755563d341b134f5caf0055993c03e59af8ec SHA512 61bb85a57dfee0be24b49cb1ea17442692ce0b86368aac2c4f3c64672912be2737255598874f724d714c095ac1a1f7016ec42968b6020698d81ab8f804b8a8c3
diff --git a/gui-apps/wf-recorder/files/wf-recorder-0.5.0-fix-build-with-no-audio.patch b/gui-apps/wf-recorder/files/wf-recorder-0.5.0-fix-build-with-no-audio.patch
new file mode 100644
index 000000000000..f1a01e9c3983
--- /dev/null
+++ b/gui-apps/wf-recorder/files/wf-recorder-0.5.0-fix-build-with-no-audio.patch
@@ -0,0 +1,48 @@
+https://github.com/ammen99/wf-recorder/pull/277
+From: =?UTF-8?q?Leonardo=20Hern=C3=A1ndez=20Hern=C3=A1ndez?=
+ <leohdz172@proton.me>
+Date: Tue, 10 Sep 2024 23:05:06 -0600
+Subject: [PATCH] fix compilation when building w/o audio support
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me>
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -611,14 +611,18 @@ static void write_loop(FrameWriterParams params)
+ uint64_t sync_timestamp = 0;
+ if (first_frame_ts.has_value()) {
+ sync_timestamp = buffer.base_usec - first_frame_ts.value();
+- } else if (pr) {
++ }
++#ifdef HAVE_AUDIO
++ else if (pr) {
+ if (!pr->get_time_base() || pr->get_time_base() > buffer.base_usec) {
+ drop = true;
+ } else {
+ first_frame_ts = pr->get_time_base();
+ sync_timestamp = buffer.base_usec - first_frame_ts.value();
+ }
+- } else {
++ }
++#endif
++ else {
+ sync_timestamp = 0;
+ first_frame_ts = buffer.base_usec;
+ }
+@@ -1136,7 +1140,11 @@ int main(int argc, char *argv[])
+ break;
+
+ case '*':
++#ifdef HAVE_AUDIO
+ audioParams.audio_backend = optarg;
++#else
++ std::cerr << "Ignoring --audio-backend. Built without audio support." << std::endl;
++#endif
+ break;
+
+ default:
+--
+2.46.2
+
diff --git a/gui-apps/wf-recorder/wf-recorder-0.5.0.ebuild b/gui-apps/wf-recorder/wf-recorder-0.5.0.ebuild
new file mode 100644
index 000000000000..14eef2e8de10
--- /dev/null
+++ b/gui-apps/wf-recorder/wf-recorder-0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Screen recorder for wlroots-based compositors"
+HOMEPAGE="https://github.com/ammen99/wf-recorder"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
+else
+ SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="pipewire pulseaudio"
+
+PATCHES=( "${FILESDIR}/${P}-fix-build-with-no-audio.patch")
+
+DEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl,wayland]
+ media-video/ffmpeg[pulseaudio?,x264]
+ x11-libs/libdrm
+ pipewire? ( >=media-video/pipewire-1.0.5:= )
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature pulseaudio pulse)
+ $(meson_feature pipewire)
+ )
+ meson_src_configure
+}