summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/ktexteditor/Manifest1
-rw-r--r--kde-frameworks/ktexteditor/files/ktexteditor-6.7.0-fix-segfault.patch70
-rw-r--r--kde-frameworks/ktexteditor/ktexteditor-6.7.0-r1.ebuild54
3 files changed, 0 insertions, 125 deletions
diff --git a/kde-frameworks/ktexteditor/Manifest b/kde-frameworks/ktexteditor/Manifest
index 826d2ca722c7..6fa8bc825ae3 100644
--- a/kde-frameworks/ktexteditor/Manifest
+++ b/kde-frameworks/ktexteditor/Manifest
@@ -1,4 +1,3 @@
DIST ktexteditor-5.116.0.tar.xz 2791176 BLAKE2B 7fb32bb7d18ccf43e33f66b0401fc086597145e3838e84a4333f99b3725e64c82ea5f78daf5fc58dfb13ea0452e85a64d1d03a503b363bba8247e26c922fd396 SHA512 9d17558e4f7adc5de1dec0af9ba32b2eb086def576dd32d3458b91d9f0424aa86505a57ab092a71f5274197bfd18927b7ccddf221551cd42d2a96f22394495e0
DIST ktexteditor-6.10.0.tar.xz 2927232 BLAKE2B ca85b14863e9467bc17d31f79dbb10e1e21af63fc680c5a8fb0e698c4d65f26d0f46442b5752d07e837b14579dd600e271e41ed40e82678b37324934afb0699d SHA512 3c2d03ac4993931c3230addeeb650d21950231e4b40b4daed4e81d90ad87fef8d551fc88ab247182097de5ddd05f7c8eab1ea6f9928410671fd06012e372c221
-DIST ktexteditor-6.7.0.tar.xz 2880020 BLAKE2B 96f73b03b7510530a7a1caa4c276ffc9e99ea544d4754a4adb2e09f372d8835a0fafe31c550d902484c4710e2bd87b6c2ba4a7b72634d1984386e51af951c742 SHA512 cfa51dc60d20cdbdf1b88c92c14a12bbb71aa7302376f4670fc940c4c6927dd74836bb66b47c0ac23018af9e5f445f551bf7b9f1623b785b46b7bfe2c496fec1
DIST ktexteditor-6.9.0.tar.xz 2896588 BLAKE2B 9a5002f7fd5bc02c2c9859e177ec14f634d79462beef4c37dc58d75151441b7d050c89744f9c12f58cc51b8cbdc3e8d4796936f6aa5140024ba9bb4d5e83e12c SHA512 95608360a71e5647428fa6617f4be96b31886171a4586242be1fcaf23258318e4a38105d1f0c5b2be11bf722239fc2d4ce908378c551561868a42721958adc47
diff --git a/kde-frameworks/ktexteditor/files/ktexteditor-6.7.0-fix-segfault.patch b/kde-frameworks/ktexteditor/files/ktexteditor-6.7.0-fix-segfault.patch
deleted file mode 100644
index 9ae8ebff41b0..000000000000
--- a/kde-frameworks/ktexteditor/files/ktexteditor-6.7.0-fix-segfault.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 43c148b2664e15e2c517ba1eb53dc04447b7d499 Mon Sep 17 00:00:00 2001
-From: Waqar Ahmed <waqar.17a@gmail.com>
-Date: Wed, 16 Oct 2024 10:32:36 +0500
-Subject: [PATCH] Fix multiblock range handling when unwrapping line
-
-BUG: 494826
-(cherry picked from commit 2c7e0711efd65e68687d530240bb46a1cf8de122)
----
- src/buffer/katetextblock.cpp | 17 ++++++++++++-----
- 1 file changed, 12 insertions(+), 5 deletions(-)
-
-diff --git a/src/buffer/katetextblock.cpp b/src/buffer/katetextblock.cpp
-index 90ed4e480..d1e767dfd 100644
---- a/src/buffer/katetextblock.cpp
-+++ b/src/buffer/katetextblock.cpp
-@@ -219,7 +219,7 @@ void TextBlock::unwrapLine(int line, TextBlock *previousBlock, int fixStartLines
-
- // move all cursors because of the unwrapped line
- // remember all ranges modified, optimize for the standard case of a few ranges
-- QVarLengthArray<TextRange *, 32> changedRanges;
-+ QVarLengthArray<QPair<TextRange *, bool>, 32> changedRanges;
- for (TextCursor *cursor : m_cursors) {
- // this is the unwrapped line
- if (cursor->lineInBlock() == 0) {
-@@ -230,7 +230,7 @@ void TextBlock::unwrapLine(int line, TextBlock *previousBlock, int fixStartLines
- auto range = cursor->kateRange();
- if (range && !range->isValidityCheckRequired()) {
- range->setValidityCheckRequired();
-- changedRanges.push_back(range);
-+ changedRanges.push_back({range, false});
- }
- }
- }
-@@ -239,15 +239,18 @@ void TextBlock::unwrapLine(int line, TextBlock *previousBlock, int fixStartLines
- for (auto it = previousBlock->m_cursors.begin(); it != previousBlock->m_cursors.end();) {
- auto cursor = *it;
- if (cursor->lineInBlock() == lastLineOfPreviousBlock) {
-+ Kate::TextRange *range = cursor->kateRange();
-+ // get the value before changing the block
-+ const bool spansMultipleBlocks = range && range->spansMultipleBlocks();
- cursor->m_line = 0;
- cursor->m_block = this;
- m_cursors.insert(cursor);
-
- // remember range, if any, avoid double insert
-- auto range = cursor->kateRange();
- if (range && !range->isValidityCheckRequired()) {
- range->setValidityCheckRequired();
-- changedRanges.push_back(range);
-+ // the range might not span multiple blocks anymore
-+ changedRanges.push_back({range, spansMultipleBlocks});
- }
-
- // remove from previous block
-@@ -261,7 +264,11 @@ void TextBlock::unwrapLine(int line, TextBlock *previousBlock, int fixStartLines
- // fixup the ranges that might be effected, because they moved from last line to this block
- // we might need to invalidate ranges or notify about their changes
- // checkValidity might trigger delete of the range!
-- for (TextRange *range : std::as_const(changedRanges)) {
-+ for (auto [range, wasMultiblock] : changedRanges) {
-+ // if the range doesn't span multiple blocks anymore remove it from buffer multiline range cache
-+ if (!range->spansMultipleBlocks() && wasMultiblock) {
-+ m_buffer->removeMultilineRange(range);
-+ }
- // afterwards check validity, might delete this range!
- range->checkValidity();
- }
---
-2.47.0
-
diff --git a/kde-frameworks/ktexteditor/ktexteditor-6.7.0-r1.ebuild b/kde-frameworks/ktexteditor/ktexteditor-6.7.0-r1.ebuild
deleted file mode 100644
index 4fd6925c6bb8..000000000000
--- a/kde-frameworks/ktexteditor/ktexteditor-6.7.0-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PVCUT=$(ver_cut 1-2)
-QTMIN=6.6.2
-inherit ecm frameworks.kde.org
-
-DESCRIPTION="Framework providing a full text editor component"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 arm64 ~ppc64 ~riscv ~x86"
-IUSE="+editorconfig"
-
-RESTRICT="test"
-
-DEPEND="
- >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
- >=dev-qt/qtdeclarative-${QTMIN}:6
- >=dev-qt/qtspeech-${QTMIN}:6
- =kde-frameworks/karchive-${PVCUT}*:6
- =kde-frameworks/kauth-${PVCUT}*:6
- =kde-frameworks/kcodecs-${PVCUT}*:6
- =kde-frameworks/kcompletion-${PVCUT}*:6
- =kde-frameworks/kconfig-${PVCUT}*:6
- =kde-frameworks/kconfigwidgets-${PVCUT}*:6
- =kde-frameworks/kcoreaddons-${PVCUT}*:6
- =kde-frameworks/kguiaddons-${PVCUT}*:6
- =kde-frameworks/ki18n-${PVCUT}*:6
- =kde-frameworks/kiconthemes-${PVCUT}*:6
- =kde-frameworks/kio-${PVCUT}*:6
- =kde-frameworks/kitemviews-${PVCUT}*:6
- =kde-frameworks/kjobwidgets-${PVCUT}*:6
- =kde-frameworks/kparts-${PVCUT}*:6
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
- =kde-frameworks/kwindowsystem-${PVCUT}*:6
- =kde-frameworks/kxmlgui-${PVCUT}*:6
- =kde-frameworks/sonnet-${PVCUT}*:6
- =kde-frameworks/syntax-highlighting-${PVCUT}*:6
- editorconfig? ( app-text/editorconfig-core-c )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="test? ( >=kde-frameworks/kservice-${PVCUT}:6 )"
-
-PATCHES=( "${FILESDIR}/${P}-fix-segfault.patch" ) # KDE-bug 494826
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package editorconfig EditorConfig)
- )
-
- ecm_src_configure
-}