summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libbdplus')
-rw-r--r--media-libs/libbdplus/Manifest1
-rw-r--r--media-libs/libbdplus/libbdplus-0.1.2.ebuild36
-rw-r--r--media-libs/libbdplus/libbdplus-9999.ebuild36
-rw-r--r--media-libs/libbdplus/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/media-libs/libbdplus/Manifest b/media-libs/libbdplus/Manifest
new file mode 100644
index 000000000000..be5cf1a9e57c
--- /dev/null
+++ b/media-libs/libbdplus/Manifest
@@ -0,0 +1 @@
+DIST libbdplus-0.1.2.tar.bz2 319828 SHA256 a631cae3cd34bf054db040b64edbfc8430936e762eb433b1789358ac3d3dc80a SHA512 e00e7bc9f52b9275646593b753ba646b052255be94a7241965f4dbe4734f8f6a072973ed4b9997957f939236b0633897c295749f79e232188430795be5b5087b WHIRLPOOL 56ab27f0aaeaacc2cc0338091cea810da6126fd09da201084dcdf5f69e4d2b483c31a0e59004c101a900a43b7581fed03b4f1686c20531f1241f7f92291b3e55
diff --git a/media-libs/libbdplus/libbdplus-0.1.2.ebuild b/media-libs/libbdplus/libbdplus-0.1.2.ebuild
new file mode 100644
index 000000000000..e5c04bcf0f49
--- /dev/null
+++ b/media-libs/libbdplus/libbdplus-0.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.videolan.org/${PN}.git"
+else
+ SRC_URI="http://ftp.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Blu-ray library for BD+ decryption"
+HOMEPAGE="http://www.videolan.org/developers/libbdplus.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aacs static-libs"
+
+RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ dev-libs/libgpg-error[${MULTILIB_USEDEP}]
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+DOCS="ChangeLog README.txt"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ $(use_with aacs libaacs)
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libbdplus/libbdplus-9999.ebuild b/media-libs/libbdplus/libbdplus-9999.ebuild
new file mode 100644
index 000000000000..e5c04bcf0f49
--- /dev/null
+++ b/media-libs/libbdplus/libbdplus-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.videolan.org/${PN}.git"
+else
+ SRC_URI="http://ftp.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Blu-ray library for BD+ decryption"
+HOMEPAGE="http://www.videolan.org/developers/libbdplus.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aacs static-libs"
+
+RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ dev-libs/libgpg-error[${MULTILIB_USEDEP}]
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+DOCS="ChangeLog README.txt"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ $(use_with aacs libaacs)
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/libbdplus/metadata.xml b/media-libs/libbdplus/metadata.xml
new file mode 100644
index 000000000000..17b802af2afd
--- /dev/null
+++ b/media-libs/libbdplus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <use>
+ <flag name='aacs'>Add support for decryption of AACS</flag>
+ </use>
+</pkgmetadata>