summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsamplerate/libsamplerate-9999.ebuild')
-rw-r--r--media-libs/libsamplerate/libsamplerate-9999.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/media-libs/libsamplerate/libsamplerate-9999.ebuild b/media-libs/libsamplerate/libsamplerate-9999.ebuild
index e92848835512..5fd3fc1ba457 100644
--- a/media-libs/libsamplerate/libsamplerate-9999.ebuild
+++ b/media-libs/libsamplerate/libsamplerate-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,19 +18,15 @@ fi
LICENSE="BSD-2"
SLOT="0"
-IUSE="sndfile static-libs test"
-REQUIRED_USE="test? ( sndfile )"
-
-RDEPEND="
- sndfile? (
- media-libs/libsndfile:=[${MULTILIB_USEDEP}]
- )"
-# Alsa/FFTW are only consumed
-# by tests, not by the main library.
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+# Alsa/FFTW are only required for tests
+# libsndfile is only used by examples and tests
DEPEND="
- ${RDEPEND}
test? (
media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/libsndfile[${MULTILIB_USEDEP}]
sci-libs/fftw:3.0[${MULTILIB_USEDEP}]
)
virtual/pkgconfig"
@@ -43,10 +39,10 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
- $(use_enable sndfile) \
$(use_enable static-libs static) \
$(use_enable test alsa) \
- $(use_enable test fftw)
+ $(use_enable test fftw) \
+ $(use_enable test sndfile)
}
multilib_src_install_all() {