summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagstamon')
-rw-r--r--net-analyzer/nagstamon/nagstamon-3.12.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-analyzer/nagstamon/nagstamon-3.12.0.ebuild b/net-analyzer/nagstamon/nagstamon-3.12.0.ebuild
index a162f8f7d2a3..132181cc389e 100644
--- a/net-analyzer/nagstamon/nagstamon-3.12.0.ebuild
+++ b/net-analyzer/nagstamon/nagstamon-3.12.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 virtualx
distutils_enable_tests pytest
@@ -58,3 +58,7 @@ src_prepare() {
rm -rf "${S}/Nagstamon/thirdparty/Xlib/" || die
}
+
+python_test() {
+ virtx epytest
+}