summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/libnfs/files')
-rw-r--r--net-fs/libnfs/files/libnfs-1.5.0-headers.patch42
-rw-r--r--net-fs/libnfs/files/libnfs-1.8.0-makefile.patch38
-rw-r--r--net-fs/libnfs/files/libnfs-1.9.5-headers.patch86
-rw-r--r--net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch27
4 files changed, 193 insertions, 0 deletions
diff --git a/net-fs/libnfs/files/libnfs-1.5.0-headers.patch b/net-fs/libnfs/files/libnfs-1.5.0-headers.patch
new file mode 100644
index 000000000000..68ec6d3c71c6
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.5.0-headers.patch
@@ -0,0 +1,42 @@
+From 32bd77c82fe12fbfe0a1d50f64fa1959cf699bea Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 3 Dec 2012 22:30:04 -0500
+Subject: [PATCH] fix implicit decl warnings
+
+Include the proper headers to fix these warnings:
+libnfs-sync.c:1529:3: warning: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration]
+libnfs-zdr.c:506:2: warning: implicit declaration of function 'getuid' [-Wimplicit-function-declaration]
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/libnfs-sync.c | 1 +
+ lib/libnfs-zdr.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/lib/libnfs-sync.c b/lib/libnfs-sync.c
+index fd6f796..1fbeb8f 100644
+--- a/lib/libnfs-sync.c
++++ b/lib/libnfs-sync.c
+@@ -45,6 +45,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/lib/libnfs-zdr.c b/lib/libnfs-zdr.c
+index a243d1d..3d5fd30 100644
+--- a/lib/libnfs-zdr.c
++++ b/lib/libnfs-zdr.c
+@@ -29,6 +29,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
++#include <unistd.h>
+ #include "libnfs-zdr.h"
+
+ struct opaque_auth _null_auth;
+--
+1.7.12.4
+
diff --git a/net-fs/libnfs/files/libnfs-1.8.0-makefile.patch b/net-fs/libnfs/files/libnfs-1.8.0-makefile.patch
new file mode 100644
index 000000000000..c06ba114d1d0
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.8.0-makefile.patch
@@ -0,0 +1,38 @@
+This enables out of source build
+
+--- lib/Makefile.am 2013-10-31 05:17:49.000000000 +0400
++++ lib/Makefile.am 2014-01-07 21:23:07.281715242 +0400
+@@ -2,11 +2,11 @@
+
+ libnfs_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
+ -I$(abs_top_srcdir)/include/nfsc \
+- -I../mount \
+- -I../nfs \
+- -I../nlm \
+- -I../portmap \
+- -I../rquota \
++ -I$(abs_top_srcdir)/mount \
++ -I$(abs_top_srcdir)/nfs \
++ -I$(abs_top_srcdir)/nlm \
++ -I$(abs_top_srcdir)/portmap \
++ -I$(abs_top_srcdir)/rquota \
+ "-D_U_=__attribute__((unused))"
+
+ libnfs_la_SOURCES = \
+--- examples/Makefile.am 2013-10-31 05:17:49.000000000 +0400
++++ examples/Makefile.am 2014-01-07 21:30:34.776726611 +0400
+@@ -3,10 +3,10 @@
+ AM_CPPFLAGS = \
+ -I$(abs_top_srcdir)/include \
+ -I$(abs_top_srcdir)/include/nfsc \
+- -I../mount \
+- -I../nfs \
+- -I../rquota \
+- -I../portmap \
++ -I$(abs_top_srcdir)/mount \
++ -I$(abs_top_srcdir)/nfs \
++ -I$(abs_top_srcdir)/rquota \
++ -I$(abs_top_srcdir)/portmap \
+ "-D_U_=__attribute__((unused))"
+
+ AM_LDFLAGS = ../lib/.libs/libnfs.la -lpopt
diff --git a/net-fs/libnfs/files/libnfs-1.9.5-headers.patch b/net-fs/libnfs/files/libnfs-1.9.5-headers.patch
new file mode 100644
index 000000000000..96719ffd54c2
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.9.5-headers.patch
@@ -0,0 +1,86 @@
+From 0bfc3e09b7d7ca2b75d42c17874b89333b96f371 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 3 Dec 2012 22:30:04 -0500
+Subject: [PATCH] fix implicit decl warnings
+
+Include the proper headers to fix warnings like:
+libnfs-sync.c:1529:3: warning: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration]
+libnfs-zdr.c:506:2: warning: implicit declaration of function 'getuid' [-Wimplicit-function-declaration]
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/libnfs-sync.c | 1 +
+ lib/libnfs-zdr.c | 9 +++++++++
+ lib/libnfs.c | 1 +
+ lib/socket.c | 1 +
+ 4 files changed, 12 insertions(+)
+
+diff --git a/lib/libnfs-sync.c b/lib/libnfs-sync.c
+index 0fc1094..c140258 100644
+--- a/lib/libnfs-sync.c
++++ b/lib/libnfs-sync.c
+@@ -77,6 +77,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/lib/libnfs-zdr.c b/lib/libnfs-zdr.c
+index c32f661..b6b3ed9 100644
+--- a/lib/libnfs-zdr.c
++++ b/lib/libnfs-zdr.c
+@@ -20,6 +20,10 @@
+ * i.e. zdrmem_create() buffers.
+ * It aims to be compatible with normal rpcgen generated functions.
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #ifdef WIN32
+ #include "win32_compat.h"
+ #endif
+@@ -28,9 +32,14 @@
+ #include "aros_compat.h"
+ #endif
+
++#ifdef HAVE_ARPA_INET_H
++#include <arpa/inet.h>
++#endif
++
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
++#include <unistd.h>
+ #include "libnfs-zdr.h"
+
+ struct opaque_auth _null_auth;
+diff --git a/lib/libnfs.c b/lib/libnfs.c
+index 5692dc3..0a7d139 100644
+--- a/lib/libnfs.c
++++ b/lib/libnfs.c
+@@ -73,6 +73,7 @@
+ #include <string.h>
+ #include <assert.h>
+ #include <errno.h>
++#include <time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/lib/socket.c b/lib/socket.c
+index 3f7f89f..f8db957 100644
+--- a/lib/socket.c
++++ b/lib/socket.c
+@@ -68,6 +68,7 @@
+ #include <fcntl.h>
+ #include <string.h>
+ #include <errno.h>
++#include <time.h>
+ #include <sys/types.h>
+ #include "libnfs-zdr.h"
+ #include "libnfs.h"
+--
+2.0.0
+
diff --git a/net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch b/net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch
new file mode 100644
index 000000000000..e702c81f5cb4
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch
@@ -0,0 +1,27 @@
+From 2be32c3c41207c029f54ebd0f4aa08e216bd3c21 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 8 Aug 2014 05:45:32 -0400
+Subject: [PATCH 3/3] fix implicit decls of rpc_{g,s}et_error
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/libnfs-zdr.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/lib/libnfs-zdr.c b/lib/libnfs-zdr.c
+index b6b3ed9..90abe26 100644
+--- a/lib/libnfs-zdr.c
++++ b/lib/libnfs-zdr.c
+@@ -41,6 +41,9 @@
+ #include <time.h>
+ #include <unistd.h>
+ #include "libnfs-zdr.h"
++#include "libnfs.h"
++#include "libnfs-raw.h"
++#include "libnfs-private.h"
+
+ struct opaque_auth _null_auth;
+
+--
+2.0.0
+