summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/torsocks/files/fix-find-libc.so.patch')
-rw-r--r--net-proxy/torsocks/files/fix-find-libc.so.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/net-proxy/torsocks/files/fix-find-libc.so.patch b/net-proxy/torsocks/files/fix-find-libc.so.patch
new file mode 100644
index 000000000000..0fb1949116e1
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-find-libc.so.patch
@@ -0,0 +1,12 @@
+diff -Nuar torsocks-2.0.0-rc3.orig/configure.ac torsocks-2.0.0-rc3/configure.ac
+--- torsocks-2.0.0-rc3.orig/configure.ac 2013-11-03 13:24:51.000000000 -0500
++++ torsocks-2.0.0-rc3/configure.ac 2014-01-26 12:49:55.157606016 -0500
+@@ -132,7 +132,7 @@
+ dnl Get libc full system path. Use prefix or some hardcoded standard
+ dnl location on Unixish system.
+ AC_MSG_CHECKING(location of libc.so)
+-for DIR in "$prefix/lib" "$prefix/usr/lib" '/lib' '/usr/lib'; do
++for DIR in "$prefix/lib*" "$prefix/usr/lib*" '/lib*' '/usr/lib*'; do
+ if test "${LIBC_PATH}" = ""; then
+ LIBC_PATH=`$FIND $DIR -name "libc.so.?" 2>/dev/null | $TAIL -1`
+ fi