summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/cryptodev/cryptodev-1.9.ebuild')
-rw-r--r--sys-kernel/cryptodev/cryptodev-1.9.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sys-kernel/cryptodev/cryptodev-1.9.ebuild b/sys-kernel/cryptodev/cryptodev-1.9.ebuild
index fe0c8dfebf73..528204b81475 100644
--- a/sys-kernel/cryptodev/cryptodev-1.9.ebuild
+++ b/sys-kernel/cryptodev/cryptodev-1.9.ebuild
@@ -14,9 +14,10 @@ SLOT="0"
IUSE="examples"
DEPEND="virtual/linux-sources"
-RDEPEND=""
-#test do not compile
+
+#test requires that the module is already loaded
RESTRICT="test"
+
S=${WORKDIR}/${PN}-linux-${PV}
MODULE_NAMES="cryptodev(extra:${S})"
@@ -38,13 +39,6 @@ pkg_setup() {
export KERNEL_DIR
}
-src_prepare() {
- default
-
- # get_unused_fd was removed in 3.19
- sed -i 's,get_unused_fd(),get_unused_fd_flags(0),' ioctl.c || die
-}
-
src_install() {
linux-mod_src_install
if use examples ; then