summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild')
-rw-r--r--x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..b4a711e4ed59
--- /dev/null
+++ b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GTK-2.0 Theme Switcher"
+HOMEPAGE="http://plasmasturm.org/programs/gtk-chtheme/"
+SRC_URI="http://plasmasturm.org/programs/gtk-chtheme/${P}.tar.bz2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # QA: stop Makefile from stripping the binaries
+ sed -i -e "s:strip:true:" "${S}"/Makefile || die "sed failed"
+ epatch "${FILESDIR}"/${P}-implicit.patch
+
+ # Fix forced as-needed, bug #248655
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+
+ # Make it work with qgtkstyle, bug #250504
+ epatch "${FILESDIR}/${P}-qgtkstyle.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die "emake install failed"
+}