summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild')
-rw-r--r--x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild
new file mode 100644
index 000000000000..d1fb45e318dd
--- /dev/null
+++ b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=12
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F11_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="!x11-themes/fedora-backgrounds:11"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2010-06-21 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ # This old version doesn't have a makefile to perform install.
+ dodoc Credits || die
+
+ insinto /usr/share/backgrounds/leonidas
+ doins -r leonidas* landscape lion || die
+
+ insinto /usr/share/gnome-background-properties
+ doins desktop-*.xml || die
+}