summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/spnavcfg/spnavcfg-0.2.1.ebuild')
-rw-r--r--x11-misc/spnavcfg/spnavcfg-0.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/spnavcfg/spnavcfg-0.2.1.ebuild b/x11-misc/spnavcfg/spnavcfg-0.2.1.ebuild
new file mode 100644
index 0000000..633a331
--- /dev/null
+++ b/x11-misc/spnavcfg/spnavcfg-0.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="GTK-based GUI to configure a space navigator device"
+HOMEPAGE="http://spacenav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/spacenav/spacenavd%20config%20gui/${PN}%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-libs/spacenavd"
+
+src_prepare() {
+ rm configure || die
+ mv Makefile{.in,} || die
+}
+
+src_compile() {
+ # TODO Improve build system upstream
+ emake CFLAGS="${CFLAGS} $(pkg-config --cflags gtk+-2.0)" \
+ LDFLAGS="${LDFLAGS} $(pkg-config --libs gtk+-2.0)" \
+ CC=$(tc-getCC) \
+ || die
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die
+}