summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/opencaster/files/opencaster-3.2.2-patch-tun-path.patch')
-rw-r--r--media-tv/opencaster/files/opencaster-3.2.2-patch-tun-path.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-tv/opencaster/files/opencaster-3.2.2-patch-tun-path.patch b/media-tv/opencaster/files/opencaster-3.2.2-patch-tun-path.patch
new file mode 100644
index 0000000..f18ed2c
--- /dev/null
+++ b/media-tv/opencaster/files/opencaster-3.2.2-patch-tun-path.patch
@@ -0,0 +1,23 @@
+diff --git a/libs/Makefile b/libs/Makefile
+index 23d951b..c442057 100755
+--- a/libs/Makefile
++++ b/libs/Makefile
+@@ -1,4 +1,4 @@
+-SUBDIRS = sectioncrc dvbobjects
++SUBDIRS = sectioncrc
+
+ subdirs: $(SUBDIRS)
+ $(SUBDIRS):
+diff --git a/tools/mpe2sec/mpe.c b/tools/mpe2sec/mpe.c
+index 18417af..1b3777a 100644
+--- a/tools/mpe2sec/mpe.c
++++ b/tools/mpe2sec/mpe.c
+@@ -12,7 +12,7 @@
+ #include <sys/socket.h>
+ #include <net/if.h>
+
+-#include <net/if_tun.h>
++#include <linux/if_tun.h>
+
+ #include "sectioncrc.h"
+