summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@sulliman.(none)>2008-12-18 12:43:15 -0500
committerroot <root@sulliman.(none)>2008-12-18 12:43:15 -0500
commit043d4f5fb2e4991dda77269f63adb292e1ac017e (patch)
tree7f2f1056c94288650a8f0a8c885a64cfaa1f4b34
parentAdd modified distcc which has a cross-compile flag which makes the (diff)
downloadeatnumber1-043d4f5fb2e4991dda77269f63adb292e1ac017e.tar.gz
eatnumber1-043d4f5fb2e4991dda77269f63adb292e1ac017e.tar.bz2
eatnumber1-043d4f5fb2e4991dda77269f63adb292e1ac017e.zip
Updated ebuild to distcc-3.1
-rw-r--r--sys-devel/distcc/Manifest3
-rw-r--r--sys-devel/distcc/distcc-3.1.ebuild172
2 files changed, 174 insertions, 1 deletions
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 885d2a4..a4bf190 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -7,5 +7,6 @@ AUX distcc-3.0-uninitialized.patch 448 RMD160 706d9923d257f7616775d55b287e02fb13
AUX distcc-3.0-xinetd.patch 558 RMD160 c69f8a379ec543972fac6ec3066989c5393223f3 SHA1 58d4393c6cdd3546f35efc57021de496c66c239d SHA256 9ef11743e91167548ac6324aa21608a62fd09149a8dbdbab32602f70804e0560
AUX distcc-hardened.patch 1084 RMD160 0f11c9c8e8b56e91399b054fb57566e290a0baa5 SHA1 746f1905a9bc45ea7b71d71f4b1feba7d96d0f7f SHA256 dcf63f201cb7f4bf13eeb1485a5056c64370b9239d28e4acc77a47046dcda6cf
DIST distcc-3.0.tar.bz2 582700 RMD160 1e187fe09129dcc6e561bfb0cd0db9a43619acca SHA1 90cea1d7500e95d3c698e6ab9b9536a946f62824 SHA256 bb6f5674b619ef1438da67739d982e8a6b11e01f748708e0fcbe371c02f020fe
+DIST distcc-3.1.tar.bz2 588820 RMD160 82229c230e6917b0df7db275460579b02dbf6b60 SHA1 30663e8ff94f13c0553fbfb928adba91814e1b3a SHA256 f55dbafd76bed3ce57e1bbcdab1329227808890d90f4c724fcd2d53f934ddd89
EBUILD distcc-3.0-r4.ebuild 4832 RMD160 8806b10df9b6fd46b1d1e964202ea0b29832d216 SHA1 27bc4778ad2c59a63ebaebfb0871bec7fc53a466 SHA256 2c42054a651f354a9ba993bbc3ecd9c23c1532ca312ceea1357807776644fc7a
-MISC .distcc-3.0-r4.ebuild.swp 20480 RMD160 5a14529ecaf641d713200d96fb9009c9914b4b17 SHA1 b11db4d7cbf0a6d0d5a3c9a08747ef3622fae4f8 SHA256 f8a9b620a3f0af051599175285d056c998b381725b93e6a8c695408bf6dbca9e
+EBUILD distcc-3.1.ebuild 4610 RMD160 59a3b7b8d5f36cda2eae973a4df11b464452f830 SHA1 03dabdb10cf5a64ff6c05302896319281e46754c SHA256 34871dbe737dc02ec979e66ec440f788069c7b560d5875de19d98ac7d777e8d8
diff --git a/sys-devel/distcc/distcc-3.1.ebuild b/sys-devel/distcc/distcc-3.1.ebuild
new file mode 100644
index 0000000..bec4e2c
--- /dev/null
+++ b/sys-devel/distcc/distcc-3.1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.1.ebuild,v 1.1 2008/12/03 09:19:07 matsuu Exp $
+
+inherit eutils fdo-mime flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.org/"
+SRC_URI="http://distcc.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi gnome gtk hardened ipv6 selinux xinetd cross-compile"
+
+RESTRICT="test"
+
+RDEPEND=">=dev-lang/python-2.4
+ dev-libs/popt
+ avahi? ( >=net-dns/avahi-0.6 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=x11-libs/gtk+-2
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ !net-misc/pump
+ >=sys-devel/gcc-config-1.3.1
+ selinux? ( sec-policy/selinux-distcc )
+ xinetd? ( sys-apps/xinetd )"
+
+DISTCC_LOG=""
+DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
+DISTCC_VERBOSE="0"
+
+pkg_setup() {
+ enewuser distcc 240 -1 -1 daemon
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.0-xinetd.patch"
+ sed -i -e "/PATH/s:\$distcc_location:${DCCC_PATH}:" pump.in || die
+
+ # Bugs #120001, #167844 and probably more. See patch for description.
+ use hardened && epatch "${FILESDIR}/distcc-hardened.patch"
+}
+
+src_compile() {
+ # More legacy stuff?
+ [ "$(gcc-major-version)" = "2" ] && filter-lfs-flags
+
+ econf \
+ $(use_with avahi) \
+ $(use_with gtk) \
+ $(use_with gnome) \
+ $(use_enable ipv6 rfc2553) \
+ --disable-Werror \
+ --with-docdir="/usr/share/doc/${PF}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # In rare cases, parallel make install failed
+ emake -j1 DESTDIR="${D}" install || die
+
+ dobin "${FILESDIR}/3.0/distcc-config"
+
+ newinitd "${FILESDIR}/3.0/init" distccd
+
+ cp "${FILESDIR}/3.0/conf" "${T}/distccd"
+ if use avahi; then
+ cat >> "${T}/distccd" <<-EOF
+
+ # Enable zeroconf support in distccd
+ DISTCCD_OPTS="\${DISTCCD_OPTS} --zeroconf"
+ EOF
+ fi
+ doconfd "${T}/distccd"
+
+ cat > "${T}/02distcc" <<-EOF
+ # This file is managed by distcc-config; use it to change these settings.
+ DISTCC_LOG="${DISTCC_LOG}"
+ DCCC_PATH="${DCCC_PATH}"
+ DISTCC_VERBOSE="${DISTCC_VERBOSE}"
+ EOF
+ doenvd "${T}/02distcc"
+
+ # create the masquerade directory
+ dodir "${DCCC_PATH}"
+ if use cross-compile; then
+ exeinto "${DCCC_PATH}"
+ cat > "${T}/${CTARGET:-${CHOST}}-wrapper" <<-EOF
+ #!/bin/bash
+ exec ${DCCC_PATH}/${CTARGET:-${CHOST}}-g\${0:\$[-2]} "\$@"
+ EOF
+ doexe "${T}/${CTARGET:-${CHOST}}-wrapper"
+ fi
+ for f in cc c++ gcc g++; do
+ if use cross-compile; then
+ dosym "${DCCC_PATH}/${CTARGET:-${CHOST}}-wrapper" "${DCCC_PATH}/${f}"
+ else
+ dosym /usr/bin/distcc "${DCCC_PATH}/${f}"
+ fi
+ if [ "${f}" != "cc" ]; then
+ dosym /usr/bin/distcc "${DCCC_PATH}/${CTARGET:-${CHOST}}-${f}"
+ fi
+ done
+
+ # create the distccd pid directory
+ keepdir /var/run/distccd
+ fowners distcc:daemon /var/run/distccd
+
+ if use gnome || use gtk; then
+ einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
+ einfo "This is to have a little sensability in naming schemes between distccmon programs"
+ mv "${D}/usr/bin/distccmon-gnome" "${D}/usr/bin/distccmon-gui" || die
+ dosym distccmon-gui /usr/bin/distccmon-gnome
+ fi
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins "doc/example/xinetd" distcc
+ fi
+
+ rm -rf "${D}/etc/default"
+ rm -f "${D}/etc/distcc/clients.allow"
+ rm -f "${D}/etc/distcc/commands.allow.sh"
+ prepalldocs
+}
+
+pkg_postinst() {
+ use gnome && fdo-mime_desktop_database_update
+
+ if use ipv6; then
+ elog
+ elog "IPv6 has not supported yet by ${P}."
+ fi
+ elog
+ elog "Tips on using distcc with Gentoo can be found at"
+ elog "http://www.gentoo.org/doc/en/distcc.xml"
+ elog
+ elog "How to use pump mode with Gentoo:"
+ elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
+ elog "# pump emerge -u world"
+ elog
+ elog "To use the distccmon programs with Gentoo you should use this command:"
+ elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-text 5"
+
+ if use gnome || use gtk; then
+ elog "Or:"
+ elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-gnome"
+ fi
+
+ elog
+ elog "***SECURITY NOTICE***"
+ elog "If you are upgrading distcc please make sure to run etc-update to"
+ elog "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
+ elog "added security precautions (the --listen and --allow directives)"
+ elog
+}
+
+pkg_postrm() {
+ use gnome && fdo-mime_desktop_database_update
+}