aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2015-07-12 12:13:38 +0200
committerNicholas Fish <gentoo@seaofdirac.net>2015-07-12 12:13:38 +0200
commitb53dfae4ac6bba1d8d316a21324ca15fb918ba03 (patch)
tree8662653ed203cec82cf11225ef1f7c3ba2af68b3
parentMerge app-misc/watchman ebuild from https://github.com/maarons/overlay (diff)
downloadennui-b53dfae4ac6bba1d8d316a21324ca15fb918ba03.tar.gz
ennui-b53dfae4ac6bba1d8d316a21324ca15fb918ba03.tar.bz2
ennui-b53dfae4ac6bba1d8d316a21324ca15fb918ba03.zip
Add watchman 3.3 release
-rw-r--r--app-misc/watchman/Manifest1
-rw-r--r--app-misc/watchman/watchman-3.3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/watchman/Manifest b/app-misc/watchman/Manifest
index 5645c96..76c1cdc 100644
--- a/app-misc/watchman/Manifest
+++ b/app-misc/watchman/Manifest
@@ -5,3 +5,4 @@ EBUILD watchman-2.7.ebuild 1610 SHA256 c47ada88507d3976cc478c27caa5e667f563eef83
EBUILD watchman-2.8.2.ebuild 1592 SHA256 fa7ad9970af16927d31468f0f2f2ea5085e778f6532409bff53e31901f9a5fb4 SHA512 3426914fb8fb89309ea290f9aaae1699b4860c7a79fc2e243d47221d73aa2db39514bc7b3cc3ff2833c0d1db24fc7f279c851f973eb2d581f2d5e1f397a0c0cc WHIRLPOOL e6e13fa8bd42b4b93d9da243f4587f418cdd245936901ca9d073088c500c766aeddc1aad4d9183bac6870a2163d9b1406ca5b3483a7e80f1b69f4c7cf7405993
EBUILD watchman-2.9.3.ebuild 1592 SHA256 fa7ad9970af16927d31468f0f2f2ea5085e778f6532409bff53e31901f9a5fb4 SHA512 3426914fb8fb89309ea290f9aaae1699b4860c7a79fc2e243d47221d73aa2db39514bc7b3cc3ff2833c0d1db24fc7f279c851f973eb2d581f2d5e1f397a0c0cc WHIRLPOOL e6e13fa8bd42b4b93d9da243f4587f418cdd245936901ca9d073088c500c766aeddc1aad4d9183bac6870a2163d9b1406ca5b3483a7e80f1b69f4c7cf7405993
EBUILD watchman-3.0.0.ebuild 1528 SHA256 a9ca9a16f04ed7722764b4f54f7c969707bffe9694bafdc257a5e079c3a65f56 SHA512 058477e85b2e64eeb775a4a39d583a30a79650a5b260b87e1fb0806229a45ea511882be2943965a5e36d82cd5f7fd0dcc19166d713973b77616d388542da582d WHIRLPOOL 9a2d3b1d07e9d1dcb1414857c5e70ab3e1a4b854ebc79bd10c7fdedbe0c84b150dd4ae7db6eedaf59cbffd80f94c5b5c7f02d225ead904940c4dfe889392b8c0
+EBUILD watchman-3.3.0.ebuild 1528 SHA256 a9ca9a16f04ed7722764b4f54f7c969707bffe9694bafdc257a5e079c3a65f56 SHA512 058477e85b2e64eeb775a4a39d583a30a79650a5b260b87e1fb0806229a45ea511882be2943965a5e36d82cd5f7fd0dcc19166d713973b77616d388542da582d WHIRLPOOL 9a2d3b1d07e9d1dcb1414857c5e70ab3e1a4b854ebc79bd10c7fdedbe0c84b150dd4ae7db6eedaf59cbffd80f94c5b5c7f02d225ead904940c4dfe889392b8c0
diff --git a/app-misc/watchman/watchman-3.3.0.ebuild b/app-misc/watchman/watchman-3.3.0.ebuild
new file mode 100644
index 0000000..57ff661
--- /dev/null
+++ b/app-misc/watchman/watchman-3.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright (c) 2015 Marek Sapota
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation
+# files (the "Software"), to deal in the Software without
+# restriction, including without limitation the rights to use,
+# copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following
+# conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="A file watching service."
+HOMEPAGE="https://facebook.github.io/watchman/"
+
+EGIT_REPO_URI="https://github.com/facebook/watchman.git"
+SRC_URI=""
+if [[ ${PV} == "9999" ]]; then
+ EGIT_COMMIT="master"
+else
+ EGIT_COMMIT="v${PV}"
+fi
+inherit git-2
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"