aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/efitools/efitools-1.7.0-r1.ebuild')
-rw-r--r--app-crypt/efitools/efitools-1.7.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/efitools/efitools-1.7.0-r1.ebuild b/app-crypt/efitools/efitools-1.7.0-r1.ebuild
new file mode 100644
index 0000000..b0de54b
--- /dev/null
+++ b/app-crypt/efitools/efitools-1.7.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: f5357a38b8ea8ddb6ff06fb92d50f7aac8b64b40 $
+
+EAPI="6"
+
+DESCRIPTION="Tools for manipulating UEFI secure boot platforms"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/efitools.git"
+SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/jejb/efitools.git/snapshot/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ >=sys-boot/gnu-efi-3.0u
+ app-crypt/sbsigntool
+ virtual/pkgconfig
+ dev-perl/File-Slurp"
+
+S=${WORKDIR}/v${PV}
+
+src_prepare() {
+ default
+ cd "${S}/lib/asn1" || die && perl oid.pl
+}