summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2011-09-05 18:20:55 -0400
committerAaron Mavrinac <mavrinac@gmail.com>2011-09-05 18:20:55 -0400
commit38399eec8cf104bdee45188a0517e44cfebc46a0 (patch)
tree4b4c16bfa4c171cd22eb0621c312c7d180679150 /dev-python
parentRetire dev-python/python-twitter as it is in the official tree. (diff)
downloadezod-38399eec8cf104bdee45188a0517e44cfebc46a0.tar.gz
ezod-38399eec8cf104bdee45188a0517e44cfebc46a0.tar.bz2
ezod-38399eec8cf104bdee45188a0517e44cfebc46a0.zip
Version bump dev-python/visual to 5.71.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/visual/visual-5.71.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/visual/visual-5.71.ebuild b/dev-python/visual/visual-5.71.ebuild
new file mode 100644
index 0000000..ecc0205
--- /dev/null
+++ b/dev-python/visual/visual-5.71.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.4.ebuild,v 1.4 2011/01/15 15:41:39 maekke Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit flag-o-matic python versionator
+
+MY_P="${PN}-$(delete_version_separator 2)_release"
+
+DESCRIPTION="Real-time 3D graphics library for Python"
+HOMEPAGE="http://www.vpython.org/"
+SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
+
+IUSE="doc examples"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+LICENSE="visual"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-cpp/libglademm
+ >=dev-cpp/gtkglextmm-1.2
+ dev-python/numpy
+ dev-python/polygon
+ >=dev-python/ttfquery-1.0.4
+ dev-python/fonttools"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ echo "#!/bin/bash" > py-compile
+ python_src_prepare
+}
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ # We have to use a hack here because the build system doesn't provide a way to specify
+ # the include and lib directory for boost.
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
+ python_src_configure \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-example-dir=/usr/share/doc/${PF}/examples \
+ $(use_enable doc docs) \
+ $(use_enable examples)
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+
+ dodoc authors.txt HACKING.txt NEWS.txt || die "dodoc failed"
+
+ # Don't install useless vpython script.
+ rm -fr "${ED}usr/bin"
+}
+
+pkg_postinst() {
+ python_mod_optimize vis visual
+}
+
+pkg_postrm() {
+ python_mod_cleanup vis visual
+}