aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-01-24 19:45:32 -0800
committerGregory M. Tuner <gmt@be-evil.net>2014-01-24 19:45:32 -0800
commit2c27d5c6ffcaa83540a4e107329ccc2732da321c (patch)
treea66b84aff579ad384b3b563a82576674a71b1702 /dev-python
parentdev-python/notify-python: clone upstream (diff)
downloadgmt-2c27d5c6ffcaa83540a4e107329ccc2732da321c.tar.gz
gmt-2c27d5c6ffcaa83540a4e107329ccc2732da321c.tar.bz2
gmt-2c27d5c6ffcaa83540a4e107329ccc2732da321c.zip
dev-python/notify-python: multilib-python header finding support
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/notify-python/Manifest2
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r4.ebuild16
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/notify-python/Manifest b/dev-python/notify-python/Manifest
index 48d62d2..d2e78d9 100644
--- a/dev-python/notify-python/Manifest
+++ b/dev-python/notify-python/Manifest
@@ -1,5 +1,5 @@
AUX notify-python-0.1.1-libnotify-0.7.patch 916 SHA256 aa40124e42ab1a843c0c1e99d4f4b2e74f5fc2e9eb2a1dff4f35973a61e6c40a SHA512 1b8c1e315ecd842925335d2115a941df47569a9557e79eca734a051e838418d0fe0d315e4f8b41de219662271dbb6e1faa8398374d1728e92263c84feb0ccc66 WHIRLPOOL 460d1aa8de138e0a69b7a4893f2070b7338ce7c7d00462cc6f7d04e88be766702528693ebcfb0bde70d5e6dbb8b4a4f1427d9a33da02f59e348d8430b3741d76
DIST notify-python-0.1.1.tar.bz2 214514 SHA256 7d3bbb7c3d8f56c922cc31d02ef9057a4f06998cc2fd4f3119a576fcf8d504ce SHA512 67021af81d77b6a1ead4ee2a0ab4e8684c2b60c672ab7aa09a8f89d71cf646453d9be76455ac28616d70645019946db1731a7021fbb91fe66d9e057fcb3815a0 WHIRLPOOL 106e71668290ebba145cc88542aac6dbe63eebcac84f7eced68256536b9fe8f3a574bad90362e07c993fdb88df2712826d8d0aa75b7f7a3c8bf5013d3cb3263c
-EBUILD notify-python-0.1.1-r4.ebuild 1254 SHA256 d8355e9b3b34cc02a2333da123e3ed1089ca0221244cf4cd16f2a295dce65dc4 SHA512 6db5524eb14e94e5bf15e465d5a69537f584e1d44438b96cacd5777a5100d9e865a7c67318ae95daad1c1ac1da8a89a49b9c1e52baee0041ab70cfa0c2de3308 WHIRLPOOL e37df4a4ec2a201a0d2efa1b469b96f9d141fb5de4021b265f3b219c8862c26b42146b0524278182cd25ea7d50760e62627f7754752687a55ea685dc02067b46
+EBUILD notify-python-0.1.1-r4.ebuild 1499 SHA256 ea143ee78b7e470800d98380216c06a491533217f60e1fe55f79756e4d0335a0 SHA512 7e89c9a9adc256302c93a30efa26a10e80372af75963cc70f42fa702e1781006b4de43f6dd57c123d27ac009e9447c697efe7acba6e13a775389318b5a74f852 WHIRLPOOL 13b56384d1803dd1c3b1c17970ebd906ff4c9c80ec5c1ade31de22a35d7d760605c86413a652d0e2f72b65f9d5ecba82faf6e97d48a8694a3e1f67f0d822cd0d
MISC ChangeLog 5988 SHA256 604bd3a6f44c6cf130bcbcb1f1eef13cf06fab19e5fa51d3e844a4615da24841 SHA512 7b21bd482e834b50b79e4d0e7f11d5d6a38d9a0b7ee073b297f22b475ca80b8d1d204ae26ae9b7e1acb5b186aeabc938a4151beac9bb5810223e30ef4e7fc692 WHIRLPOOL e1bc8ca02b483bc5c207fae00d7753089aa7b145cd22e0e2421224db3e812f950450483da40208f60891a2070204659355e15ac4d3a82ef84cdd66565936fc7b
MISC metadata.xml 264 SHA256 99d84181942576a6dccd9991e6aacb76319789bba3bf11595d51abf58488e5c0 SHA512 c7fd8837c4c78021c4ba57aeb1c085d9eb6a53ce65d198de855649032ac1de1cf99a2a485380a8ba2a77cd91fb216599047bb65c731cbfba656745a9e75c2c2f WHIRLPOOL 0e2a3a2255ec2bdf216cabfdfbc589ca7d7718cf1ba18b1e9bb9c52731836e451419da129e6ab028941b1b27e5cb2e190c6c8f11e1b6b11a203e53af81efb9d5
diff --git a/dev-python/notify-python/notify-python-0.1.1-r4.ebuild b/dev-python/notify-python/notify-python-0.1.1-r4.ebuild
index a1b8a5a..1147879 100644
--- a/dev-python/notify-python/notify-python-0.1.1-r4.ebuild
+++ b/dev-python/notify-python/notify-python-0.1.1-r4.ebuild
@@ -31,20 +31,28 @@ src_prepare() {
autotools-utils_src_prepare
}
+_flagwrap() {
+ local CFLAGS="${CFLAGS} $(python_get_CFLAGS)"
+ local CXXFLAGS="${CXXFLAGS} $(python_get_CFLAGS)"
+ local CPPFLAGS="${CXXFLAGS} $(python_get_CFLAGS)"
+ export CFLAGS CXXFLAGS CPPFLAGS
+ "$@"
+}
+
src_configure() {
- python_foreach_impl autotools-utils_src_configure
+ python_foreach_impl _flagwrap autotools-utils_src_configure
}
src_compile() {
- python_foreach_impl autotools-utils_src_compile
+ python_foreach_impl _flagwrap autotools-utils_src_compile
}
src_test() {
- python_foreach_impl autotools-utils_src_test
+ python_foreach_impl _flagwrap autotools-utils_src_test
}
src_install() {
- python_foreach_impl autotools-utils_src_install
+ python_foreach_impl _flagwrap autotools-utils_src_install
prune_libtool_files --all
# Requested from bug 351879.