summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2017-05-13 15:25:05 +0200
committerhaarp <main.haarp@gmail.com>2017-05-13 15:25:05 +0200
commit5da29c25971e40a26d6eb3e0967112d01c041ee9 (patch)
treec65795b28947a2ad6256fa3c0c545c35096dd202 /app-editors
parentForgot the stupid manifest yet again (diff)
downloadhaarp-5da29c25971e40a26d6eb3e0967112d01c041ee9.tar.gz
haarp-5da29c25971e40a26d6eb3e0967112d01c041ee9.tar.bz2
haarp-5da29c25971e40a26d6eb3e0967112d01c041ee9.zip
Add Xed, the gedit/Pluma successor
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xed/Manifest2
-rw-r--r--app-editors/xed/xed-1.4.1.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/app-editors/xed/Manifest b/app-editors/xed/Manifest
new file mode 100644
index 0000000..31b9324
--- /dev/null
+++ b/app-editors/xed/Manifest
@@ -0,0 +1,2 @@
+DIST xed-1.4.1.tar.gz 3947711 SHA256 f3490cb2dac8d910dfc231325b66703b2afefdb1b4a8466fed4f7e70c972f0c5 SHA512 aa1d25a54c6cc90b9251615e67433bfb6215248348efd8c704c734d8d563b12ab5ec7f9677fbf9e2527de1016c7e8017a88b30066932c2cb0f592b4c3a287714 WHIRLPOOL 2d10120807f74b1e8c085a80555a2e866a0b301e71a6f7df838d56caad125895800bd518458f28eca42deedddfe61eac2d599ce3448b86ac4bd04f3fc76ca9df
+EBUILD xed-1.4.1.ebuild 2117 SHA256 b9d3adc34f4480b010e67de140319301bf3483fb11d85fe041fdaf19e33c2b86 SHA512 2f4d9758bc6b1a48aebe5698916c5b5b37858158abf8ffc6464efe6fb7e6c4775e48348c5a606c3027559a58045b3852be1854bb4e62bd96e1db38867b19ad32 WHIRLPOOL 0009a878ea5fa39ef4f2d06ab1d9660b794d9fd3ea36da0aa14b1768099a4a5b55f46ad6732ee99a5d6167a394e0a3d59bb1aa6777027f640e3561b117b9031b
diff --git a/app-editors/xed/xed-1.4.1.ebuild b/app-editors/xed/xed-1.4.1.ebuild
new file mode 100644
index 0000000..e329139
--- /dev/null
+++ b/app-editors/xed/xed-1.4.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_4 )
+
+inherit autotools eutils gnome2 multilib python-r1 #virtualx
+
+DESCRIPTION="X-Apps [Text] Editor (Cross-DE, backward-compatible, GTK3, traditional UI)"
+HOMEPAGE="https://github.com/linuxmint/xed"
+SRC_URI="https://github.com/linuxmint/xed/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python spell test"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+# we need to fix that
+REQUIRED_USE="
+ python? ( ^^ ( $(python_gen_useflags '*') ) )
+"
+
+KEYWORDS="~amd64 ~x86"
+
+# X libs are not needed for OSX (aqua)
+COMMON_DEPEND="
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/glib-2.44:2[dbus]
+ >=x11-libs/gtk+-3.16:3[introspection]
+ >=x11-libs/gtksourceview-3.18:3.0[introspection]
+ >=dev-libs/libpeas-1.14.1[gtk]
+
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+
+ x11-libs/xapps
+ x11-libs/libX11
+ net-libs/libsoup:2.4
+
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[${PYTHON_USEDEP}] )
+ spell? (
+ >=app-text/enchant-1.2:=
+ >=app-text/iso-codes-0.35 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+# yelp-tools, gnome-common needed to eautoreconf
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_prepare() {
+eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ gnome2_src_configure \
+ --enable-gvfs-metadata \
+ $(use_enable spell) \
+ $(use_enable python) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+}