summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2010-11-09 01:24:00 +0100
committerHenry Gebhardt <hsggebhardt@googlemail.com>2010-11-09 01:25:25 +0100
commitc4b98f9c0f8e11337dd0348b7ea7d06d57894d16 (patch)
tree4c9fbfacbfd1eb09d278b539ede00de23921e238 /sci-astronomy
parentgames-simulation/numptyphysics-157: Minor version bump (diff)
downloadkork-c4b98f9c0f8e11337dd0348b7ea7d06d57894d16.tar.gz
kork-c4b98f9c0f8e11337dd0348b7ea7d06d57894d16.tar.bz2
kork-c4b98f9c0f8e11337dd0348b7ea7d06d57894d16.zip
sci-astronomy/ftools-6.9-r1: Add revdep-control script
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ftools/Manifest1
-rw-r--r--sci-astronomy/ftools/ftools-6.9-r1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
index 42953e6..b6eec1c 100644
--- a/sci-astronomy/ftools/Manifest
+++ b/sci-astronomy/ftools/Manifest
@@ -1,3 +1,4 @@
AUX installManPage-S-namecollision.patch 786 RMD160 82f9911c5922d02f9f0870c19b960ae17b670ad1 SHA1 3e38468fda1e1b8c17a60ae1f9e27b266958aa72 SHA256 27bd0f77c7ddaa96cac057f2e2c690188059858e6e6fe495336556fb7c5ece31
DIST heasoft6.9src.tar.gz 64709171 RMD160 e70eade8c125c47ed10bb83e1bb21fb7f3f5e229 SHA1 4c8b51f9a3a528d89065a0967bb6e0dc5f25ea30 SHA256 83df06147dc772441427c888c3c7c9d810486aad9a45208586bba56baf160ab4
+EBUILD ftools-6.9-r1.ebuild 2967 RMD160 de5922fdb1c535b3bb760241ae35151606a5a111 SHA1 4ee04aea9c8e4f2d58329b800e67ddb4c9e770fa SHA256 8adba16987ad76a43e8a63efd2592b8b716599a205da9f0cf3a3a3977be4dd89
EBUILD ftools-6.9.ebuild 2251 RMD160 b08369c20cb0901c9a64e5478a37bd6ff9f1fcaa SHA1 6d809585a4d172b93deca0d833a1984b34bd206a SHA256 7e2671f0bf9d91bfc2b9c6fd2939449a092dbfa60ac05d0d2a99ab30c018dd50
diff --git a/sci-astronomy/ftools/ftools-6.9-r1.ebuild b/sci-astronomy/ftools/ftools-6.9-r1.ebuild
new file mode 100644
index 0000000..3b7a202
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.9-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
+SRC_URI="http://localhost/heasoft${PV}src.tar.gz"
+LICENSE="UNKOWN freedist as-is GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="x11-base/xorg-server
+ >=dev-lang/perl-5.6.0
+ <dev-lang/perl-5.12.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/heasoft-${PV}/BUILD_DIR"
+PREFIX="/usr/heasoft-${PVR}"
+
+MSG="The HEASOFT General-Use FTools have been installed into
+${PREFIX}.
+
+To use the HEASOFT, you need to source the headas init script,
+like so
+ . \${HEADAS}/headas-init.sh
+if you are using a bourne-shell. As a shortcut you can put an
+alias in your ~/.bashrc:
+ alias heainit=\". \${HEADAS}/headas-init.sh\"
+
+C-shells should source \${HEADAS}/headas-init.csh instead.
+
+The environment variable \${HEADAS} has been defined for you
+globally in /etc/env.d/99headas."
+
+pkg_setup() {
+ [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
+ ewarn "This ebuild works but doesn't do things as god intended..."
+ einfo "PREFIX=${PREFIX}"
+}
+
+src_prepare() {
+ for subdir in tcl tk; do
+ cd "${S}"/../tcltk/${subdir}/unix
+ epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
+ || die "epatch failed"
+ done
+ cd "${S}"/../ftools/guis/xdf
+ sed -i '27iClientData Tk_MainWindow (Tcl_Interp *) ;' xdfShared.c || die
+}
+
+src_configure() {
+ econf --prefix="${PREFIX}" || die "econf failed"
+}
+
+src_compile() {
+ # -j1 and -j2 are ok, but -j3 is not.
+ emake -j2 || die "emake failed"
+}
+
+src_install() {
+ # The heasoft install scripts don't allow for $DESTDIR. Thus we
+ # must let headas install itself. This is very, very bad.
+ addwrite "${PREFIX}"
+ einfo "Installing into ${PREFIX} directly..."
+ # -j1 is needed, don't know why exactly
+ emake -j1 install || die "emake install failed"
+ einfo "Moving ${PREFIX} to image directory..."
+ mkdir "${D}"/usr
+ mv "${PREFIX}" "${D}"/usr
+
+ echo "${MSG}" > WTF
+ dodoc WTF
+
+ HEADAS=`grep "HD_TOP_EXEC_PFX.*= " Makefile \
+ | sed "s#^HD_TOP_EXEC_PFX.*= ##"`
+ echo "HEADAS=\"${HEADAS}\"" > 99headas
+ doenvd 99headas
+
+ einfo "Heasoft's installation is a mess. A revdep-rebuild control "
+ einfo "file is installed for ape and cfitsio, so that any dependencies "
+ einfo "won't scream everytime you run revdep-rebuild."
+ ape_so="`ls "${HEADAS}/lib/libape_*.so"`"
+ ape_so="${ape_so##*/}"
+ cfitsio_so="`ls "${HEADAS}/lib/libcfitsio_*.so"`"
+ cfitsio_so="${ape_so##*/}"
+ echo "# Heasoft's installation is a mess." > 70-heasoft
+ echo "# This file makes it slightly less annoying for other" >> 70-heasoft
+ echo "# packages using its libraries." >> 70-heasoft
+ echo >> 70-heasoft
+ echo "LD_LIBRARY_MASK=\"${ape_so} ${cfitsio_so}\"" >> 70-heasoft
+ insinto /etc/revdep-rebuild/
+ doins 70-heasoft
+}
+
+pkg_postinst() {
+ elog "${MSG}"
+}