summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'netzob-0.3.1.ebuild')
-rw-r--r--netzob-0.3.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/netzob-0.3.1.ebuild b/netzob-0.3.1.ebuild
new file mode 100644
index 0000000..0dae41a
--- /dev/null
+++ b/netzob-0.3.1.ebuild
@@ -0,0 +1,53 @@
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="Netzob-${PV}"
+
+DESCRIPTION="Network protocol modelization by reverse engineering"
+HOMEPAGE="http://www.netzob.org/"
+SRC_URI="http://www.netzob.org/repository/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORD="~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/ptrace-0.4.1
+ app-misc/hachoir-subfile
+ dev-python/matplotlib
+ dev-util/strace
+ sys-process/lsof
+ >=dev-python/lxml-2.3
+ dev-python/bitarray
+ net-libs/nfqueue-bindings[python]"
+# python-pcapy
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="README.txt AUTHORS.txt NEWS.txt COPYING.txt PKG-INFO.txt"
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+
+# if use doc; then
+# einfo "Generation of documentation"
+# pushd docs >/dev/null
+# emake html || die "Generation of documentation failed"
+# popd >/dev/null
+# fi
+}
+
+src_install() {
+ distutils_src_install
+}