summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/amass/amass-9999.ebuild')
-rw-r--r--net-analyzer/amass/amass-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-analyzer/amass/amass-9999.ebuild b/net-analyzer/amass/amass-9999.ebuild
index b130786..0049921 100644
--- a/net-analyzer/amass/amass-9999.ebuild
+++ b/net-analyzer/amass/amass-9999.ebuild
@@ -10,6 +10,7 @@ inherit go-module
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGO_VER="devel"
src_unpack() {
git-r3_src_unpack
@@ -18,17 +19,14 @@ if [[ ${PV} == *9999* ]]; then
else
EGO_VER="v${PV}"
#SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
-
- #SRC_URI+="${EGO_SUM_SRC_URI}"
- #S="${WORKDIR}/Amass-${PV}"
inherit git-r3
EGIT_REPO_URI="https://${EGO_PN}.git"
EGIT_COMMIT="${EGO_VER}"
- src_unpack() {
- git-r3_src_unpack
- go-module_live_vendor
- }
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
fi
@@ -45,17 +43,18 @@ src_compile() {
use pie && local build_pie="-buildmode=pie"
local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
+ local ld_flags=""
set -- env \
CGO_ENABLED=0 \
- go build -o "bin/${PN}" -mod=vendor -v -work -x ${build_flags} \
+ go build -o "bin/${PN}" -mod=vendor -v -work -x "${build_flags}" -ldflags "${ld_flags}" \
./cmd/${PN}
echo "$@"
"$@" || die
}
src_install() {
- dobin bin/${PN}
+ dobin bin/*
insinto /etc/amass
doins "${S}"/examples/config.ini