summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2015-01-25 19:26:54 +0100
committerPaul Labedan <plabedan@gmail.com>2015-01-25 19:44:00 +0100
commit7fc76dd5d727ea805281fd0d1885a7e619fcf389 (patch)
tree2614c9bf4f70fdae9d90816fb30f88958d4fdca4 /x11-wm
parentadd efl 1.12.3 (diff)
downloadplab-7fc76dd5d727ea805281fd0d1885a7e619fcf389.tar.gz
plab-7fc76dd5d727ea805281fd0d1885a7e619fcf389.tar.bz2
plab-7fc76dd5d727ea805281fd0d1885a7e619fcf389.zip
add enlightenment 0.19.3
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Manifest4
-rw-r--r--x11-wm/enlightenment/enlightenment-0.19.3.ebuild92
-rw-r--r--x11-wm/enlightenment/files/gentoo-sysactions.conf76
-rw-r--r--x11-wm/enlightenment/files/quickstart.diff13
4 files changed, 185 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
new file mode 100644
index 0000000..891a143
--- /dev/null
+++ b/x11-wm/enlightenment/Manifest
@@ -0,0 +1,4 @@
+AUX gentoo-sysactions.conf 3056 SHA256 5939973a9fbaaba81751e936fb541d6aebd7ec1c599174ea568f5a579356939f SHA512 688f02cbff0d50a847eb08ca7832699b836adca9b22e15a780943a8e5a8213aac04b335cfdf3cb96adbff238f681ae8954a720153e8e35b2afaba3225d53206a WHIRLPOOL 0c05e0d295ede8b2f436a87c4b98876fed64d5cc780f13bb6bde1a74a3c87847f2f90ab482a61c2b39f20894572329f5497e5da22537261eef2f0a9fb33ce56d
+AUX quickstart.diff 474 SHA256 9201674d2f8707f216e18c471f0a4a5a7366b3dd32cb8ec131ca1795a10bb3e6 SHA512 b8df654dd1246ea6391017fe9856e38d209b250625f8343aa4943a4eeed980447eb52c6a15fe170bcab90b76e5670ee9c7f98358bb87990877e312cc4cea8f6c WHIRLPOOL 7ea473b01d46ab1ae10ed50d9991de652e3c2945390a71dfa3cba4bf7c6d8ae526dbd18a275db7bd714be7e48414b90ea470c46d2460c68512ede070025b9c49
+DIST enlightenment-0.19.3.tar.bz2 26236171 SHA256 13f3579da2f35c3909569c84fc8953d0b4095877a314db93e006d0add017c382 SHA512 83f3d89b72eac31c1650adb974ac92020d65a84de75054a74ad1b372fad53bf1ce48cfe1553b64c4c0c83f8302e07e017e3d1cb05c01f0c544c8e1d2ddca39f3 WHIRLPOOL b433f99bfc1f41aa46490c34267054ef46b9f3a8f4178a1f2e4877d5a269a5f391872df04b25db62662582d518fe5209cdd9100680405ea6d587c09bc4229b95
+EBUILD enlightenment-0.19.3.ebuild 2453 SHA256 f3d4e13aa5c2ada3931d06bbf3a570e97560e5bb032de5b494bcc2dcd5a5057a SHA512 239f99489e63d721260908543f3fffbd5efaa243adc98d892750debb8419f813e22e85e4dc5aa85cd588ed5ce53cfda101e6e58db4e151edb0022ca9dbd322aa WHIRLPOOL 1754d00ce43545b45141d2f229eaef7bc4b8fadfdbd665326ac50b02c8ddadf46ee823e035196896ad66b1f32623ed61f514da75f788aff3b06cd8b081adbb76
diff --git a/x11-wm/enlightenment/enlightenment-0.19.3.ebuild b/x11-wm/enlightenment/enlightenment-0.19.3.ebuild
new file mode 100644
index 0000000..db188cc
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.19.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.18.8.ebuild,v 1.1 2014/06/09 11:25:55 tommy Exp $
+
+EAPI=5
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0.17/${PV%%_*}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@comp +@dialogs +@display
+ +@interaction +@intl +@menus
+ +@paths +@performance +@randr +@shelves +@theme +@wallpaper2
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@appmenu +@backlight +@bluez4 +@battery +@clock
+ +@connman +@contact +@cpufreq +@everything +@fileman
+ +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2 +@mixer +@msgbus
+ +@music-control +@notification +@pager +@quickaccess +@shot
+ +@start +@syscon +@systray +@tasks +@teamwork +@temperature +@tiling
+ +@winlist +@wizard @wl-desktop-shell @wl-screenshot +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="pam spell static-libs systemd +udev ukit wayland ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ wayland? ( dev-libs/efl[wayland]
+ >=dev-libs/wayland-1.2.0
+ >=x11-libs/pixman-0.31.1
+ >=x11-libs/libxkbcommon-0.3.1
+ )
+ >=dev-libs/efl-1.8.3
+ || ( >=dev-libs/efl-1.8.3[X] >=dev-libs/efl-1.8.3[xcb] )
+ >=media-libs/elementary-1.8.2
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ E_ECONF+=(
+ --disable-install-sysactions
+ $(use_enable doc)
+ --disable-device-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ $(use_enable systemd)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ $(use_enable wayland wayland-clients)
+ )
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}
diff --git a/x11-wm/enlightenment/files/gentoo-sysactions.conf b/x11-wm/enlightenment/files/gentoo-sysactions.conf
new file mode 100644
index 0000000..fe67623
--- /dev/null
+++ b/x11-wm/enlightenment/files/gentoo-sysactions.conf
@@ -0,0 +1,76 @@
+# ENLIGHTENMENT SYSTEM ACTIONS CONFIGURATION
+#
+# This is a system configuration for allowing or denying certain users or
+# groups to be able to do certain actions that involve system restricted
+# actions such as halt, reboot, suspend, hibernate etc.
+#
+# This file is read in order from top to bottom - the first rule to MATCH
+# will be used for a user or a group, and nothing after that is read.
+#
+# You must put all the ACTION definitons BEFORE user and group rule matches.
+# Any action definitons after a rule match has been found will be ignored.
+# This allows actions to be re-defined for different user groups, so matches
+# so the command for an action can change for matches to the rules later on.
+#
+# Any user or group NOT matched by an allow or a deny will be ALLOWED to
+# perform the action by default (system administrators should be aware of
+# this and implement whatever policies they see fit). Generally speaking
+# a user of a workstation, desktop or laptop is intended to have such abilities
+# to perform these actions, thus the default of allow. For multi-user systems
+# the system administrator is considerd capable enough to restrict what they
+# see they need to.
+#
+# A WARNING to admins: do NOT allow access for users to this system remotely
+# UNLESS you fully trust them or you have locked down permissions to halt/reboot
+# suspend etc. here first. You have been warned.
+#
+# FORMAT:
+#
+# action: halt /sbin/shutdown -h now
+# action: reboot /sbin/shutdown -r now
+# action: suspend /etc/acpi/sleep.sh force
+# action: hibernate /etc/acpi/hibernate.sh force
+#
+# user: username allow: halt reboot suspend hibernate
+# group: groupname deny: *
+# group: * deny: *
+# user: * allow: suspend
+# user: billy allow: halt reboot
+# group: staff deny: halt suspend hibernate
+#
+# etc.
+#
+# user and group name can use glob matches (* == all for example) like the
+# shell. as can action names allowed or denied.
+
+action: halt /sbin/shutdown -h now
+action: reboot /sbin/shutdown -r now
+action: suspend /usr/sbin/pm-suspend
+action: hibernate /usr/sbin/pm-hibernate
+
+# on FreeBSD use this instead of the above.
+#action suspend /usr/sbin/zzz
+
+# root is allowed to do anything - but it needs to be here explicitly anyway
+user: root allow: *
+# members of operator, staff and admin groups should be able to do all
+group: operator allow: *
+group: staff allow: *
+group: admin allow: *
+group: sys allow: *
+group: wheel allow: *
+# common "user" groups for "console users" on desktops/laptops
+group: dialout allow: *
+group: disk allow: *
+group: adm allow: *
+group: cdrom allow: *
+group: floppy allow: *
+group: audio allow: *
+group: dip allow: *
+group: plugdev allow: *
+# put in a list of other users and groups here that are allowed or denied etc.
+# e.g.
+# user: myuser allow: *
+# user: another allow: suspend hibernate
+# deny everyone else by default
+user: * deny: *
diff --git a/x11-wm/enlightenment/files/quickstart.diff b/x11-wm/enlightenment/files/quickstart.diff
new file mode 100644
index 0000000..c7d3f38
--- /dev/null
+++ b/x11-wm/enlightenment/files/quickstart.diff
@@ -0,0 +1,13 @@
+Index: src/bin/e_main.c
+===================================================================
+--- src/bin/e_main.c (revision 61690)
++++ src/bin/e_main.c (working copy)
+@@ -93,7 +93,7 @@
+ static Eina_Bool _e_main_cb_startup_fake_end(void *data __UNUSED__);
+
+ /* local variables */
+-static Eina_Bool really_know = EINA_FALSE;
++static Eina_Bool really_know = EINA_TRUE;
+ static Eina_Bool locked = EINA_FALSE;
+ static Eina_Bool inloop = EINA_FALSE;
+ static jmp_buf x_fatal_buff;