summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Sanda <ps@twin.jikos.cz>2011-12-04 22:00:20 +0100
committerPavel Sanda <ps@twin.jikos.cz>2011-12-04 22:00:20 +0100
commitb892dc69b412b71fbb9739fff81d2c2375dc8c8c (patch)
treea36f6f16115d1316e6c1369fb18d80ab8cc22d02 /app-office/lyx
parentdsgui in the main tree (diff)
downloadrebutia-b892dc69b412b71fbb9739fff81d2c2375dc8c8c.tar.gz
rebutia-b892dc69b412b71fbb9739fff81d2c2375dc8c8c.tar.bz2
rebutia-b892dc69b412b71fbb9739fff81d2c2375dc8c8c.zip
bump new lyx
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/Manifest2
-rw-r--r--app-office/lyx/lyx-2.0.2.ebuild182
2 files changed, 184 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index b052f33..65bdf65 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -2,6 +2,8 @@ AUX 1.6.7-python.patch 906 RMD160 74a2f14445d6b011fe04d06f3bd6710d36ab6351 SHA1
AUX lyx-1.5.0-gentoo.patch 1298 RMD160 69b7ce68234e7f5c2fee708944267f1974aa10d0 SHA1 16c3e6f846c55c3eb5fd9d7da1247a3429efa7a4 SHA256 36be1ea2577cce270319a7a3b4bed92e5925c0e974edda8729bda2179ac8ffe2
AUX lyx.desktop 215 RMD160 13192f0f4e84e870565a3daff7d46c56954ed0fe SHA1 f72f3ff17a3a1b84cbb0aaf12c9e75387879a420 SHA256 b0ffd201e0a2e0cb39a52aadb9921e86fbb31c8d3cac04526371d6606246898c
DIST lyx-2.0.1.tar.xz 10119588 RMD160 d8a4ed2f546994220ee7fc84246f1aceccaa6ed9 SHA1 225b4d853f38463e986a9b42a39cac432da56d8a SHA256 a58b7e0f27afce0497fffec0d19fc95fb1b3ac36818e8d02ecaf9e882c8f3852
+DIST lyx-2.0.2.tar.xz 10175756 RMD160 ab2436c05fd4ea2bb76111d6bab140359162b317 SHA1 47b9c7fa73ef827907622cefe78421a356481ca9 SHA256 e5eacacd200d4502808f59e244d380634dca421b2bc89a5c213b3faddadcbd18
EBUILD lyx-1.6.9999.ebuild 4197 RMD160 1fb05dc360e08c8033a3957d27c4db58b31901fe SHA1 895061e60ef59ac85f787fa5e4c1892588124276 SHA256 5c79ce22e68b93cc470f7c4aab4b35e2e5e9bb45db6ae3e10c12869c9f77262f
EBUILD lyx-2.0.1.ebuild 4606 RMD160 eedb27fcbd31a878c5f25de843767edea0663171 SHA1 dc8379f70c547b37c5254cf9d6b8af3e314f2e06 SHA256 fc5658f9ae6c2f6ef3b6556dbbb41e882dbd05ccab0d70c2a4372fa1a5594e9d
+EBUILD lyx-2.0.2.ebuild 4594 RMD160 3d66a83a48ed31b46ffcc81cb300a9ef135c37ad SHA1 0715eabc6edb89346d4b66c17c69b6fc73171156 SHA256 9a4929ccb7dc3b4bb0ad04530e645c06369bda1fc1d2d5b03acacbf914b978a8
EBUILD lyx-2.0.9999.ebuild 4608 RMD160 0c37eca4d03b54e15bc14b09b326f10880b99654 SHA1 46ef4d064b7a321dd31bc26eb32bcbc2e68a38dc SHA256 eb2bc88053baa598310e0eeea02da1d0d871879a28e6a0e4e95504f3b1e28e36
diff --git a/app-office/lyx/lyx-2.0.2.ebuild b/app-office/lyx/lyx-2.0.2.ebuild
new file mode 100644
index 0000000..dfbf8c4
--- /dev/null
+++ b/app-office/lyx/lyx-2.0.2.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.1.ebuild,v 1.2 2011/10/05 19:32:13 aballier Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.0.x/${P}.tar.xz"
+#SRC_URI="ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.0/rc3/${MY_P}.tar.xz"
+#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups debug nls +latex xetex luatex monolithic-build html rtf dot docbook dia subversion rcs svg gnumeric +hunspell aspell enchant"
+
+LANGS="ar ca cs de da el en es eu fi fr gl he hu ia id it ja nb nn pl pt ro ru sk sr sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+COMMONDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libxml2
+ media-libs/fontconfig
+ media-libs/freetype
+ >=dev-libs/boost-1.34"
+
+RDEPEND="${COMMONDEPEND}
+ dev-texlive/texlive-fontsextra
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick )
+ cups? ( net-print/cups )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/noweb
+ app-text/dvipng
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ dev-texlive/texlive-genericextra
+ dev-texlive/texlive-fontsrecommended
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ xetex? ( dev-texlive/texlive-xetex )
+ luatex? ( >=dev-texlive/texlive-luatex-2010 )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( <dev-vcs/subversion-1.7.0 )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
+ gnumeric? ( app-office/gnumeric )
+ hunspell? ( app-text/hunspell )
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )"
+
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ x11-proto/xproto
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.6.7-python.patch
+ echo "#!/bin/sh" > config/py-compile
+ sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ $(use_with hunspell) \
+ $(use_with aspell) \
+ $(use_with enchant) \
+ --without-included-boost --disable-stdlib-debug
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt || die
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
+ make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office" "MimeType=application/x-lyx;"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym /usr/share/myspell /usr/share/lyx/dicts
+ dosym /usr/share/myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}